Somme d'une cellule selon plusieurs critères JOUR,HEURE,...

engelyk44

XLDnaute Nouveau
Bonjour,
J'ai besoin de faire des statistiques en fonctions du jour de la semaine et de la tranche horaire ainsi que du type de déplacement.
Il me faut pour chaque jour de la semaine par tranche d'heure le nombre de trajet.
Les tableaux de base et final sont en pièce jointe.

On m'a déjà proposé une formule qui fonctionne sans le critère du jour de la semaine :
=SOMMEPROD(($I$4:$I$538>7/24)*($I$4:$I$538<9/24)*($Q$4:$Q$538="Héricourt"))
 

Pièces jointes

  • stats jour+heure.xls
    62 KB · Affichages: 53

hoerwind

XLDnaute Barbatruc
Re : Somme d'une cellule selon plusieurs critères JOUR,HEURE,...

Bonjour,

Essaie pour le lundi :
=SOMMEPROD(($D$4:$D$538>=10/24)*($D$4:$D$538<11/24)*($E$4:$E$538="Héricourt")*(JOURSEM($C$4:$C$538)=2))

Sous cette formule : lundi =2, mardi=3, ...
 

Excel-lent

XLDnaute Barbatruc
Re : Somme d'une cellule selon plusieurs critères JOUR,HEURE,...

Bonjour Engelyk44,

Si je peux me permettre, pour rendre tes formules plus clair et plus simple à comprendre, utilise le "nommage de cellule" ;)

Autre avantage, plus la peine d'utiliser le signe $, ainsi plus de risque de l'oublier

-> Sélectionner les cellules I4 à I538
-> "Insertion" / "nom" / "définir"
-> mettre comme nom par exemple "heure"

-> Sélectionner les cellules Q4 à Q538
-> "Insertion" / "nom" / "définir"
-> mettre comme nom par exemple "lieu"

Ainsi ta fonction ci-dessus deviendra :
=SOMMEPROD((heure>7/24)*(heure<9/24)*(lieu="Héricourt"))

Ce qui te permet de voir que ta formule est ainsi constitué :
=SOMMEPROD((condition 1)*(condition 2)*(condition 3)*(quoi faire dans ce cas? Somme, addition, ...))

Et ainsi tu n'as plus de mal à rajouter tes conditions supplémentaires.

Bonne après midi
 
Dernière édition:

engelyk44

XLDnaute Nouveau
Re : Somme d'une cellule selon plusieurs critères JOUR,HEURE,...

Oui, je l'ai vu en plus, je m'y perds puisque j'ai plusieurs questions en cours.
Cette formule marche, le problème c'est que pour chaque cellule je suis obligé de rentrer chaque critères qui correspond, je ne m'en sors pas.
 

sakina001

XLDnaute Nouveau
Re : Somme d'une cellule selon plusieurs critères JOUR,HEURE,...

salut

pouvez vous m'aider SVP
c'est ce que je souhaite faire

exemple jai 5 A et parmis ces 5 jai 3 remplis

a 1
a 1
a 1
a
a
alors je veux la somme des A non remplis et la somme des A remplis
a=5
a=3
je suis encore débutante
MERCI
 

JHA

XLDnaute Barbatruc
Re : Somme d'une cellule selon plusieurs critères JOUR,HEURE,...

Bonjour à tous,

Avec les données en A1:B5

Pour les "a" remplis
=SOMMEPROD(($A$1:$A$5="a")*($B$1:$B$5>0))
pour les "a" non remplis
=SOMMEPROD(($A$1:$A$5="a")*($B$1:$B$5=0))

JHA
 

Membres actuellement en ligne

Statistiques des forums

Discussions
288 664
Messages
1 893 837
Membres
170 101
dernier inscrit
Lupinps
Haut Bas