XL 2010 Somme d'heures en fonction d'un critère

tweety57

XLDnaute Nouveau
Bonjour,

Je suis entrain de mettre en place un planning et je n'arrive pas à faire ma synthèse d'heures.

Voici le principe :
- 1 ligne = 1 jour
- 1 ensemble de colonne pour chaque activité de la journée avec heure de début, heure de fin, temps passé (=heure de fin - heure de début), type d'activité (Q,S,E,A,C) et détail de l'activité

Je suis arrivée à faire le calcul de temps passé par activité.
Par contre, je n'arrive pas à faire mon calcul par activité.
exemple : somme des temps passés sur l'activité Q pour la journée 3. J'obtiens la notification #VALEUR!

Je vous ai mis une copie du fichier en cours de conception en PJ.
 

Fichiers joints

tbft

XLDnaute Accro
bonsoir
pouvez-vous regardez la formule suivante:
=SOMME(E5*(F5=$BL$3);J5*(K5=$BL$3);O5*(P5=$BL$3);T5*(U5=$BL$3);Y5*(Z5=$BL$3);AD5*(AE5=$BL$3);AI5*(AJ5=$BL$3);AN5*(AO5=$BL$3);AS5*(AT5=$BL$3);AX5*(AY5=$BL$3);BC5*(BD5=$BL$3);BH5*(BI5=$BL$3))
àmettre en BL5
un peu lourde mais j'ai pas mieux pour l'instant..
 

tweety57

XLDnaute Nouveau
Rebonjour, c'est de nouveau moi avec mon fichier de planning.
La formule fonctionne toujours aussi bien par contre je voudrais la faire évoluer et je n'y arrive pas.
Jusqu'à présent la somme se faisait sur un critère de type Q,S,E,A ou C. Hors j'ai des domaines qui peuvent être de type QS, QSE, QE, SE etc. Comment faire pour que si j'ai un domaine en QS par exemple, le temps passé soit calculé dans la somme Q et la somme S?
Je vous joins le fichier .

Merci d'avance.
 

Fichiers joints

gosselien

XLDnaute Barbatruc
Bonjour,

QS n'est donc pas le total de Q+S ?
Si c'est "QS" , tu peut écrire le "QS" en dur dans la formule en BQ4:

=SOMMEPROD((MOD(COLONNE($C4:$BI4);5)=1)*($C4:$BI4="QS");$B4:$BH4)

Idem pour QSE et autres...
Pas certain d'avoir compris :)

P.
 

tweety57

XLDnaute Nouveau
Bonsoir gosselien,

Effectivement QS n'est pas Q+S, c'est le nombre d'heures QS affectée à Q et à S. Ex : 10 heures QS = 10 heures Q et aussi 10 heures S.
J'ai essayé la formule cela ne fonctionne pas. Cela me donne le résultat 0.
 

tweety57

XLDnaute Nouveau
Si on prend la ligne d'exemple :
- les 50 min QSE (9:10 à 10:00) soit totalisées dans la colonne Q, aussi dans la colonne S et dans la colonne E
- les 45 min Q (10:00 à 10:45) soit uniquement totalisées dans la colonne Q
etc.

Au final sur cette ligne je devrais avoir dans la colonne Q = 6:50, S =0:50, E =0:50, A = 1:15

Dans l'idéal, il faudrait même pousser plus loin en pro-ratisant le temps.
Si domaine QSE : 1/3 du temps dans Q, 1/3 du temps dans S et 1/3 du temps dans E
Si domaine QE : 1/2 du temps dans Q, 1/2 du temps dans E
Si domaine QS : 1/2 du temps dans Q, 1/2 du temps dans S
Si domaine SE : 1/2 du temps dans S, 1/2 du temps dans E

Ex :
50 min (9:10 à 10:00) QSE en colonne E13 = 0:17 dans Q, 0:17 dans S et 0:17 dans E
45 min (10:00 à 10:45) Q en colonne J13 = 0:45 dans Q
cela donnerait en cumul de ces 2 périodes de travail (de 9:10 à 10:45) Q (BL13) = 1:02, S (BM13) = 0:17, E (BN13)= 0:17
et ainsi de suite pour l'ensemble des domaines de la ligne 13
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas