Redistribuer information de colonne en ligne

gibtoul

XLDnaute Junior
Bonjour a tous

Je joins mon tableau pour être plus clair dans mon explication
J'ai des informations saisie dans des cellules dont les références en colonnes

Je souhaiterai retravailler ces données en ligne

Ma difficulté est pouvoir dupliquer les lignes suivant un nombre de ligne prédéfini

Vous remerciant pour votre aide

Gibtoul
 

Fichiers joints

vgendron

XLDnaute Barbatruc
Re : Redistribuer information de colonne en ligne

Et pour ajouter une ligne vide entre les différentes références..en B15
Code:
=SI(MOD((LIGNE()-15);($A$12+1))=$A$12;"";INDEX(TabData;COLONNE()-1;NON(MOD((LIGNE()-15);($A$12+1))=$A$12)*ENT((LIGNE()-15)/($A$12+1))+1))
 

Fichiers joints

Dernière édition:

gibtoul

XLDnaute Junior
Re : Redistribuer information de colonne en ligne

Bonjour vgendron

Je te remercie pour ton retour
Si je veux mettre la formule dans un autre onglet , quel modification dois-je appliquer à la formule ?
J'ai essayé de rajouté Feuil1! mais cela ne fonctionne pas

A bientôt
Gibtoul
 

vgendron

XLDnaute Barbatruc
Re : Redistribuer information de colonne en ligne

à priori, il n'y a pas de modif à faire,
il suffit de recopier la formule dans ton autre feuille. à la MEME cellule: B15

ou alors..avec quelques modifs
mais si tu veux faire commencer à la première ligne il faut ajuster le ligne()-15 dans la formule ainsi que le "colonne()-1"


voir PJ
pour la formule dans la feuil2:
le TabData reste défini dans la feuille 1: pas besoin de préciser à la formule où se trouve ce tableau (c'est tout l'intéret des Zones nommées: tu peux les déplacer, les formules restent valables)
la nombre de lignes à dupliquer (5) est restée en Feuil1 A12: donc la. il faut préciser à la formule (idem: tu pourrais définir la cellule A12 avec un nom et y faire référence dans la formule
ligne()-15 devient ligne()-2 car le tableau commence en ligne 2
colonne()-1) devient colonne() car le tableau commence en colonne A
 

Fichiers joints

Discussions similaires


Haut Bas