Office 365 recherchev avec deux conditions

benoit06190

XLDnaute Nouveau
Bonjour à tous,
Un peu d'aide n'est pas de refus, je vous explique mon problème.
J'ai un fichier " membres" avec une liste de noms'A1", prénoms"B1" , dates de naissance"C1", adresses"D1" etc.….
et ensuite un autre fichier "saison 2019" avec les membres qui reprennent leurs cotisations.
En "A1" j'écris le nom, et en A2,A3,A4 j'utilise la formule SI et RECHERCHEV, mais le problème se pose quand j'ai deux personnes qui portent le même noms, excel ne prends que le premier.
Je voudrais savoir s'il existe une solution à ce problème.
Merci d'avance
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour.

Plusieurs solutions :
- Une colonne supplémentaire avec un n° d'adhérent (unique)
- Une colonne supplémentaire avec concaténation des nom et prénom (BENOIT ZEROSIX pourrait donner BENZER...)
-
Et bonjour à Staple1600 qui m'a devancé :)
 

benoit06190

XLDnaute Nouveau
Re, en fait non, il ne prends que le nom qu'il l'intéresse.
je joins un modèle de mon fichier avec l'erreur.
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

La fonction recherchev() ne prend pas les valeurs situées à gauche de la recherche, tu peux essayer:
VB:
=SIERREUR(INDEX(A$3:A$8;EQUIV($K3;$C$3:$C$8;0));"")
Copier vers le bas et la droite

JHA
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Re, Benoît06190, bonjour JHA

Le N° de licence étant unique, pourquoi utiliser la concaténation ?
PS : Placez-le en 1° colonne si vous voulez utiliser recherchev() :)
 

benoit06190

XLDnaute Nouveau
Bonjour Victor,
Je ne commence pas par le n° de licence parce qu'ils n'en ont pas tous, et, c'est plus facile pour moi de les trouver par leurs noms.
En te remerciant, et te souhaite une bonne journée
 

Discussions similaires


Haut Bas