Pourriez vous m'aider à améliorer ma formule de calcul de temps

tipoone

XLDnaute Nouveau
Bonjour,

Je souhaiterais ajouter 6 mois à une date, j'ai donc utilisé cette formule : =DATE(ANNEE(A2);MOIS(A2)+6;JOUR(A2))
(la date initiale se trouve dans la cellule A2). Jusque la tout va bien.

Mais j'ai quelques difficultés pour la suite... Je m'explique : Un salarié est embauché le 02/01/2010, dans 6 mois il va passé à la position 2 donc le 02/07/2012. Le problème c'est que je ne peux changer la position d'un salarié que le 1er du mois. Dans cet exemple le salarié ne pourra passer a la position 2 qu'au 01/08/2012. J'aimerai donc que excel rajoute un mois à l'échéance si elle ne tombe pas un 1er du mois. MAIS que si l’échéance tombe un premier du mois, que excel ne rajoute pas 1 mois (exemple si le salarié avait été embauché le 01/01/2012 alors sont passage à la position 2 se ferait le 01/07/2012)...

Voici donc mon exemple en pièce jointe.

Merci d'avance pour votre aide et bonne soirée :)
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Re : Pourriez vous m'aider à améliorer ma formule de calcul de temps

Bonjour le Forum,
Bonjour tipoone,

A tester en B2 et à étiré vers le bas :

Code:
=SI(DATE(ANNEE(A2);MOIS(A2)+6;JOUR(A2))>DATE(ANNEE(A2);MOIS(A2)+6;1);DATE(ANNEE(A2);MOIS(A2)+7;1);DATE(ANNEE(A2);MOIS(A2)+6;JOUR(A2)))
Cordialement
 

Habitude

XLDnaute Accro
Re : Pourriez vous m'aider à améliorer ma formule de calcul de temps

Bonjour tipoone, Jocelyn

Une autre variante

Code:
=DATE(ANNEE(A2);MOIS(A2)+6+SI(JOUR(A2)=1;0;1);JOUR(A2))
 

tipoone

XLDnaute Nouveau
Re : Pourriez vous m'aider à améliorer ma formule de calcul de temps

OUAWW vous êtes trop forts merci beaucoup. J'aimerais trop maitriser comme vous. Je sais que j'en demande bcp mais pourriez vous m'expliquer ces formules ?? :) Pour ma culture personnelle ...

Merci encore
 

tipoone

XLDnaute Nouveau
Re : Pourriez vous m'aider à améliorer ma formule de calcul de temps

AA il y a tout de même un soucis avec les formules que vous m'avez proposer... Lorsque je tape comme date en A2 : 31/02/2012 il y a écrit "valeurs"...

Merci a vous
 

Jocelyn

XLDnaute Barbatruc
Re : Pourriez vous m'aider à améliorer ma formule de calcul de temps

re,
Bonjour Habitude,

Hum hum il me semble logique que lorsque tu tapes 31/02/2012 tu es en retour une erreur vu que cette date n'existe pas février ayant suivant les années au maximum 29 jours et bien plus souvent seulement 28
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas