Impossible de créer une macro

G

guy

Guest
Bonjour à tous

Depuis une semaine, je rencontre un sacré problème sous excel que je n'arrive pas à résoudre.

Je ne peux plus créer de nouvelle macro. Lorsque je passe soit en direct par l'icône "enregistrer une macro" ou par le menu "outils", le résultat est le même.

Toute l'exécution pour créer ma nouvelle macro se passe bien, je peux également cliquer sur le carré "arréter l'enregistrement" pour la terminer. Mais quand je vais ensuite dans Visual Basic, alors là, la macro est vide, il n'y a juste son nom et la date d'enregistrement.

J'espère que l'un ou l'une d'entre vous pourra me donner un petit tuyau pour me sortir de ce pétrin. Car j'ai la forte impression que ça sent le virus, j'espère me tromper et je compte beaucoup sur votre aide.

Merci à tous

cordialement

Guy
 
D

DAn

Guest
Bonjour,

Bizarre cela. Vérifie dans VBA (ALT+F11) que dans menu / outils / préférences les quatres premières options sont cochées (visual Basic applications, etc ....)

Dans l'attente de te lire

@+ Dan
 
G

guy

Guest
Bonjour Dan,

Merci tout d'abord de t'interesser à mon triste sort. Malheureusement, n'étant pas chez moi avant demain après-midi, je ne pourrai vérifier dans BVA que demain (je te réponds du boulot).

Donc, aussitôt que j'aurai regardé ça de près, je te fais savoir ce qu'il en est.

Salut et encore merci pour ce premier tuyau.

Guy
 
G

guy

Guest
Bonjour dan,

Tout d'abord, dans le message précédent, j'ai écrit "BVA" (du nom d'un sondage dans la presse écrite) au lieu de "VBA", autant pour moi.

Le mystère des macros disparues est résolu mais paradoxalement demeure toujours. Car je viens d'essayer d'en créer deux et elles sont bien maintenant dans Visual Basic. Et je n'ai rien corriger dans le menu "Options".

Peut-être 2 choses à retenir:

1- N'ai-je pas mis un nom de macro interdit ? Peu de chance quand même car il me semble que les cinq dernières étaient par défaut (macro1...Macro2...Etc) et que ces noms là, me semble t-il sont refusés d'office.

2- Par contre, il y a quelques jours, je sais que j'ai du réinstaller les fichiers d'aide car cet été je suis passé à XP. Alors, y a t'il eu un changement dans la config. Mystère...

Mais le vrai mystère c'est justement qu'hier il y en avait un et qu'aujourd'hui il n'y en a plus.

Le positif de tout çà, c'est qu'hier, ce problème m'a permis de découvrir ce forum rempli de gens sympas prêts à dépanner les autres. Alors, à mon tour d'essayer d'apporter des solutions et à bientôt sur le site.

Encore merci à toi.

Guy
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas