« Document non enregistré », puis « erreur automation »

MisterT

XLDnaute Occasionnel
:confused:Bonjour, j’ai besoin d’aide pour résoudre le problème suivant :

J'utilise VISTA Familial...J’ai un fichier Excel 2003 sur le bureau contenant plusieurs macros. Tout d’un coup je ne peux plus faire de sauvegarde (enregistrer), le message suivant apparaît : « Document non enregistré », je clique OK puis j’assai les fonctions avec des boutons (Macros) et le message « Erreur automation » apparaît et plus rien ne fonctionne.
Si je ferme le fichier et l’ouvre à nouveau, tout fonctionne normalement mais je ne peux l’enregistrer.

Voici ce que j’ai essayé pour tenter de résoudre le problème, mais en vain :

1) La dernière sauvegarde qui a fonctionnée était le 11 août et depuis il y a eu des mises à jour le 14 et 21 août. J’ai donc fait une restauration du système qui n’allait qu’au 21 août, je ne pouvais le faire pour le 14.

2) J’ai réinstallé Excel 2003

3) J’ai fait INFO(?) puis « Détecter et réparer »

4) J’ai essayé le « Enregistrer sous… »

5) De mon serveur de site web, J’avais une copie du fichier fonctionnel du 11 août que j’ai déposé sur le bureau et le problème est encore présent.

6) J’ai aussi une copie de ce fichier dans un dossier et je l’ai ouvert à partir du dossier et le problème persiste.

7) J’ai essayé le fichier sur un ordi XP avec Excel 2003 et le message suivant est apparu : « Impossible de charger l’objet car il n’est pas disponible sur cette machine ».

Voilà, est-ce qu’un spécialiste ou quelqu’un qui a eu un problème similaire pourrait m’aider, ce serait grandement apprécié ?

Merci,
MisterT
:)
 
Dernière édition:

BrunoM45

XLDnaute Barbatruc
Re : « Document non enregistré », puis « erreur automation »

Bonjour MisterT ;)

As-tu essayé de mettre ton fichier ailleurs que sur le bureau, sur une partition D: par exemple ?

Utilises-tu des DTPickers ?

A+
 

MisterT

XLDnaute Occasionnel
Re : « Document non enregistré », puis « erreur automation »

Bonjour BrunoM45 !

Merci pour ton message !!!

Oui, j'ai mis le fichier dans un dossier et le problème demeure. J'ai aussi une copie du fichier sur un disque dur externe et à l'ouverture à partir du disque externe, c'est le message "Erreur automation" qui apparaît directement.

Désolé, j'ignore ce que sont des DTPickers...

Merci,
MisterT:)
 

MJ13

XLDnaute Barbatruc
Re : « Document non enregistré », puis « erreur automation »

Bonjour MisterT, Bruno

Il faudrait déjà savoir ce que contient ton fichier.

Si c'est un problème récurrent des listviews, teste ce fichier.
 

Fichiers joints

fhoest

XLDnaute Accro
Re : « Document non enregistré », puis « erreur automation »

Bonjour MisterT,BrunoM45,MJ13

Peut être tu trouvera la solution dans ce fil,
Si j'ai bon souvenir on a déjà travaillé ensemble. (Canada c'est bien ça)

Au plaisir.
 

Numidia

XLDnaute Occasionnel
Re : « Document non enregistré », puis « erreur automation »

bonjour tt le monde
j'ai eu le meme probleme QUE vous mr mistert et j'ai reussi à le regler par deux procedures distinctes
le probleme provient essentiellement des controls listviews
donc commence par la premiere procedure suivante (il faut aller par etape):
1-demarrer
2-Accessoires
3-Invite de commandes
4-vous cliquer sur button droit de la souris pour excuter "invite de commandes" en tant Administrateur (etape importante)
5-ecrire ceci:Regsvr32 C:\Windows\system32\MSCOMCTL.OCX
vous faiites Entrer et vous aurez comme message
DllRegisterServer dans C:\windows\System32\MSCOMCTL.OCX réussi

deuxieme procedure:
changer les listviews que vous avez dans votre application sans supprimer les codes qui les regissent autrement dit supprimez les et changez les par des nouveaux listviews et normalement le message ne s'affichera plus
et tenez moi au courant si ca marchera et merci
u
 

MisterT

XLDnaute Occasionnel
Re : « Document non enregistré », puis « erreur automation »

Bonjour MJ13, fhoest et Numidia !!!

Merci infiniment pour vos réponses respectives qui sont vraiment très intéressantes, je dois quitter et ferai les essais plus tard et reviendrai avec les résultats...

Bonne mémoire fhoest, je suis bien du Canada et je me souviens aussi de toi et ton aide très précieuse, merci encore !!!

À bientôt,
MisterT :)
 

MisterT

XLDnaute Occasionnel
Re : « Document non enregistré », puis « erreur automation »

RE-bonjour chers MJ13, fhoest et Numidia !!! :)

SUPER ! Grâce à vos réponses, le problème est solutionné...

Étant loin d'être spécialiste, j'ai fait différents essais à partir de vos 3 réponses pour finalement résoudre le problème.

Voici ce que j'ai fait en abrégé:

1) J'ai fait la première étape et une partie de la 2e étape suggérée de Numidia. J'ignorais comment ajouter le ListView après l'avoir supprimée puisqu'elle n'apparaissait pas dans la boite d'outil.

2) Avec les infos de MJ13 et le fil de fhoest j'ai cliqué bouton droit sur la boite d'outil avec le Userform ouvert, j'ai sélectionné "Contrôles supplémentaires" puis j'ai coché "Microsoft ListView Control. version 6.0(SP6)". Le Contrôle ListView est donc apparu dans la boite d'outils.

3) j'ai donc ajouté le ListView à la place de celui que j'avais supprimé et j'ai ENREGISTRÉ et tout a fonctionné.

Merci encore infiniment MJ13, fhoest et Numidia, c'est grandement apprécié !!!

MisterT :)
 

Numidia

XLDnaute Occasionnel
Re : « Document non enregistré », puis « erreur automation »

Bonjour tt le monde bonjour Mistert je suis trés ravi que votre probleme soit solutionné
bonne journée
 

Discussions similaires


Haut Bas