XL 2016 Calcul en fonction de 3 colonnes (Nbre - Dates - Agent)

celudic

XLDnaute Nouveau
Bonjour-Bonsoir,

Je suis en train de faire un tableau à 3 colonnes
A: le nombre de pages
B: la date de sortie
C: l'agent

J'ai besoin de la formule magique pour démontrer qui fait quoi : "combien de pages par mois par tel agent"
J'arrive à avoir "combien par tel agent" sur toute la période mais pas combien par mois...
A force de me casser la tête, ça me les brise…
et j'ai besoin de ce résultat pour prouver que je ne suis pas en reste sur la fab, c'est juste que je bosse plus vite ;-)

Merci de votre attention.
Irène
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonsoir celudic,

Mal fichu votre tableau : il y a des valeurs sous forme de textes en colonne A !!!

Voyez le fichier joint et les formules matricielles en G2 et G5 à valider par Ctrl+Maj+Entrée et tirer où il faut.

Seules les données avec des dates sont comptées.

Nota : c'est le premier tableau qui doit être un tableau Excel structuré, pas le second.

A+
 

Fichiers joints

celudic

XLDnaute Nouveau
Merci beaucoup pour votre réactivité, le tableau était une copie de celui de mon chefaillon qui me cherche les poux...
Je vais jeter un œil demain et je le lui mets dans la face.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Ajout d'une colonne pour les dates, problème nombre de pages en format texte.

JHA
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour celudic, JHA, le forum,

Merci JHA, tu m'as permis de voir que mon tableau A:C n'allait pas jusqu'en bas (à cause de la ligne vide 1265), je viens de corriger mon fichier.

Il reste cependant des divergences, chez moi il y a :

- 58 pages de plus en juin pour "IA"

- 480 pages en juin pour "OR"

- 72 pages de plus de novembre à février pour "Reste".

Bonne journée.
 

job75

XLDnaute Barbatruc
Je sais d'où viennent nos différences JHA :

- pour "IA" et "OR" tu n'as pas entré de formules dans la plage C1707:C1723

- pour "Reste" il n'y a pas que la valeur zéro à rechercher en colonne D, il y a aussi "JOUVE/AG", "CF et OR", "CF prépaOR", "CF prepa EY".
 

JHA

XLDnaute Barbatruc
Bonjour à tous,
Bonjour job75 :) ,

Je t'avoue que je n'ai pas regardé si il y avait des différences entre les deux fichiers. J'ai simplement essayé de contourner le problème des dates avec la fonction sommeprod().
Avec une approche plus sérieuse

JHA
 

Fichiers joints

job75

XLDnaute Barbatruc
JHa pour corriger la colonne "Reste" tu peux mettre en N8 de ton dernier fichier :
Code:
=SOMMEPROD((MOIS($C$3:$C$1723)=MOIS($H8))*(ANNEE($C$3:$C$1723)=ANNEE($H8))*(NB.SI(I$1:M$1;$E$3:$E$1723)=0)*$A$3:$A$1723)
qui donne bien un total de 3973.
 

celudic

XLDnaute Nouveau
Les résultats de vos travaux ont été percutants… le chefaillon est en arrêt maladie.
Merci. Et paf
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas