[XL-2000] Macro de totalisation par chaîne

juju05

XLDnaute Junior
Bonjour à tous,

Je souhaite faire une macro qui fasse les choses suivantes sur le classeur joint :

- remplacer le caractère "," par "." en colonne D,

- supprimer les lignes pour lesquelles la chaîne est "absences",

- effectuer une totalisation des heures effectives par couple atelier/chaîne sur l'ensemble des colonnes de la feuille (la ligne "total" est positionnée de manière variable suivant la journée traitée),

- si le terme "total" apparaît en colonne A, il faut le supprimer en colonne B et C,

- si le terme "total" apparaît en colonne B, il faut le supprimer en colonne C et mettre en jaune la ligne concernée.

Merci d'avance.

Bonne journée.
 

Fichiers joints

Dernière édition:

mutzik

XLDnaute Barbatruc
Re : [XL-2000] Macro de totalisation par chaîne

Bonjour,

il est sur qu'il a lu la charte, le sieur juju05, dans laquelle il est indiqué qu'on a le droit de dire bonjour, merci, et toutes ces genres de choses relevant de la politesse la plus élémentaire ...
 

juju05

XLDnaute Junior
Re : [XL-2000] Macro de totalisation par chaîne

Bonjour,

il est sur qu'il a lu la charte, le sieur juju05, dans laquelle il est indiqué qu'on a le droit de dire bonjour, merci, et toutes ces genres de choses relevant de la politesse la plus élémentaire ...
Effectivement, milles excuses. Je n'ai eu que quelques minutes. Je rectifie tout çà.
 

juju05

XLDnaute Junior
Re : [XL-2000] Macro de totalisation par chaîne

Merci beaucoup.

J'ai mis en jaune les lignes de totalisation que je souhaite obtenir. Il me faut remplir les celulles que j'ai valorisé à la main avec la fonction somme.

Les lignes de totalisation ne se trouvent pas à des cellules fixes, c'est pourquoi il me faut faire une macro.

Merci d'avance.
 

Fichiers joints

mutzik

XLDnaute Barbatruc
Re : [XL-2000] Macro de totalisation par chaîne

re,

je ne sais toujours pas quelles colonnes doivent être 'totalisées' et ou ce total doit figurer
Sinon, il n'y a forcément besoin d'une macro pour le faire, la fonction (une fonction est toujours beaucoup plus rapide que du VBA) somme.si sert à cela

j'attends tes infos avec, stp, un exemple de ce que tu attends
 

juju05

XLDnaute Junior
Re : [XL-2000] Macro de totalisation par chaîne

Bonsoir,

Ma classeur Excel est issu d'une extraction d'un outil décisionnel par copier-coller.

Je parle par rapport au classeur Excel mis en pièce-jointe dans mon précédent message.

Les valeurs sont ensuite rentrées sur Excel par les utilisateurs sur les lignes de détail entre les colonnes E et O.

Je souhaite avoir des totalisations par colonne (de E à O) à chaque fois qu'apparaît le terme "Total" en colonne C.

Le terme "Total" n'apparaît jamais au même endroit, c'est pourquoi il me semble que j'ai besoin d'une macro.

Merci d'avance.
 

mutzik

XLDnaute Barbatruc
Re : [XL-2000] Macro de totalisation par chaîne

re,

par ex :
en Q3 : =SI(C3="TOTAL";SOMME(E3:O3);"*")
et recopier vers le bas
 

juju05

XLDnaute Junior
Re : [XL-2000] Macro de totalisation par chaîne

J'ai dû mal m'exprimer.

Je veux effectuer le calcul en E7 par exemple. Cela correspondrait à SOMME(E3:E6). Le problème et que la ligne de totalisation n'est pas forcément à la 7ème ligne.
 
Haut Bas