Transfert de données d'une cellule à l'autre

D

Domi

Guest
Bonsoir à tous,

Un court exemple vaut mieux qu'un long discours, tout est expliqué dans l'exemple à télécharger.

--------------------------
Merci d'avance pour votre aide. [file name=exemple_20060102220120.zip size=6908]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/exemple_20060102220120.zip[/file]
 

Fichiers joints

Robert

XLDnaute Barbatruc
Bonsoir Domi, bonsoir le forum,

Juste en cliquant dans une cellule, je pense que seule une macro événementielle pourra y réagir. Par formule on devrait pouvoir arriver à un résultat similaire mais il te faudrait, je pense, éditer quelquechose dans la cellule.

Il me semble donc impossible que l'on puisse y parvenir sans macro.

Toutefois, je me suis fait si souvent reprendre pour des affirmations erronnées dans ce forum que j'émets des tonnes de réserves (naturelles, d'indiens et même pétrolières...)
 
D

Domi

Guest
Salut Robert,
C'est justement en passant par une formule que cela m'interresse, mais je n'y arrive pas.
Peux-tu m'éclairer stp ?

Merci
 

coco_lapin

XLDnaute Impliqué
Bonsoir Domi, Robet et le forum.

Il faut savoir que les fonctions Excel sont des macros personnalisées et par définition sont limitées.

Je rejoins Robert, qui marche sur des oeufs, mais tu as trouvé une solution, pourquoi veux-tu changer de méthode? Pour apprendre autre chose? Qu'est-ce qui te perturbes? L'utilisation d'une macro eveneventielle?

Domi, nous nous sommes croisés. OK je vais y réfléchir.

Message édité par: coco_lapin, à: 02/01/2006 22:24
 

Robert

XLDnaute Barbatruc
Bonjour Domi, Coco, bonjour le forum,

Une solution bien moins efficace que la macro (mais, je le confesse, je suis nul en formules...) puisqu'il faut taper 3 dans les cellules C3, C4, C7 ou C8. Mais pire encore, il faut effacer ce 3 en C3 avant de le taper en C4 (ou inversement) et idem pour C7 et C8.

Bref, ça marche mais tellement mal qu'il faudrait un(e) crac(esse) des formules pour lui appporter des béquilles et un kiné pendant 6 mois...

place cette formule en E5 : =SI(C3=3;B3;SI(C4=3;B4;''))
et celle-ci en E6 : =SI(C7=3;B7;SI(C8=3;B8;''))
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas