Tester la présence d'une date dans une cellule

carole29

XLDnaute Nouveau
Bonjour,
Je dois réaliser une application excel dans laquelle l'utilisateur rentrera une date dans une cellule. Il faut donc qu'en cas de mauvaise saisie, un message d'erreur s'affiche. Voici la formule que j'ai crée : =SI(ESTERREUR(CHERCHE("??/??/????";B1;1));"Veuillez saisir une date valide";"") Cependant, il y a un problème, car si je rentre 15/11/2008 dans la cellule, la fonction cherche renvoie un message d'erreur, alors qu'elle devrait renvoyer "1". Par contre, si je rentre 15/11/2008gfhhrt par exemple, la ça marche, la fonction cherche renvoie "1". Auriez vous une solution afin que la fonction cherche renvoie "1" en rentrant uniquement la date?
Merci beaucoup
 

Denis132

XLDnaute Impliqué
Re : Tester la présence d'une date dans une cellule

Bonjour Carole29,

Tu peux aussi le faire par: "Donnees", "Validation des donnees" puis autoriser seulement date.

@+

Denis

Ta fonction "Cherche" recherche du texte et non une date voilà pourquoi ça ne fonctionne pas avec une date mais oui avec le texte 15/11/2008gfhhrt
 
Dernière édition:

Staple1600

XLDnaute Barbatruc
Re : Tester la présence d'une date dans une cellule

Bonjour


Un début de solution (trés imparfait)

=SI(GAUCHE(CELLULE("format";C9);1)="D";"datevalide";"date invalide")
 

BrunoM45

XLDnaute Barbatruc
Re : Tester la présence d'une date dans une cellule

Bonsoir à tous,

Une autre formule plus simpliste :

=SI(ESTERREUR(B1-MAINTENANT());"Veuillez saisir une date valide";"")

On soustrait à la date saisie, la date du jour, retourne une erreur si ce n'est pas une date ;)

A+
 

carole29

XLDnaute Nouveau
Re : Tester la présence d'une date dans une cellule

Merci beaucoup pour vos réponses, j'ai enfin solutionné mon problème.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas