XL 2010 Renseigner une cellule avec 3 critères

Isaleen

XLDnaute Nouveau
Bonsoir à tous,

je suis toute nouvelle sur le forum et suite contente d’être parmi vous. J’ai besoin d’aide : je recherche une formule qui pourrait renseigner ma cellule selon 3 critères. Une date, un nom, une heure
A2 nom
B1 date
B2 heure
Si ma condition est remplie alors Ma formule irait chercher les données dans un autre tableau dans la colonne D.

je sais pas si je suis clair mais merci d’avance pour votre aide et si besoin j’enverrai un ptit tableau recap....
 

laurent3372

XLDnaute Impliqué
Bonjour,

Voici une solution. J'ai modifié ta feuille pour que les listes déroulantes affichent les valeurs du tableau.
En D2 : =SI(E2=0;"Non Trouvé";INDEX(Tableau1[résultat];E2))
En E2 : =SOMMEPROD(($A3=Tableau1[nom])*(B3=Tableau1[date])*(C3=Tableau1[heure])*(LIGNE(Tableau1[résultat])-1))
 

Pièces jointes

  • Classeur recherche (1).xlsx
    11.8 KB · Affichages: 7

Isaleen

XLDnaute Nouveau
Bonjour,

Voici une solution. J'ai modifié ta feuille pour que les listes déroulantes affichent les valeurs du tableau.
En D2 : =SI(E2=0;"Non Trouvé";INDEX(Tableau1[résultat];E2))
En E2 : =SOMMEPROD(($A3=Tableau1[nom])*(B3=Tableau1[date])*(C3=Tableau1[heure])*(LIGNE(Tableau1[résultat])-1))
Bonsoir,

alors voici mon fichier.
en fonctions des 3 critères en cellule b10;a11 et b11si ces 3 critères sont réunis dans le tableau a1:j8 alors ma cellule b12 doit être égale à D2; b13 doit être égal à e2 et ainsi de suite... en espérant que se soit un peu plus clair...
 

Pièces jointes

  • 0DB6CFC4-A2D7-4E3E-A7F6-74EFCAB821B9.jpeg
    0DB6CFC4-A2D7-4E3E-A7F6-74EFCAB821B9.jpeg
    23.3 KB · Affichages: 3

Isaleen

XLDnaute Nouveau
Bonsoir,

alors voici mon fichier.
en fonctions des 3 critères en cellule b10;a11 et b11si ces 3 critères sont réunis dans le tableau a1:j8 alors ma cellule b12 doit être égale à D2; b13 doit être égal à e2 et ainsi de suite... en espérant que se soit un peu plus clair...

la qualité de l’image est pourrie... comment je fait pour mettre une pièce jointe ?...
 

Isaleen

XLDnaute Nouveau
Bonjour à tous,

En attendant ton tableau récap...

JHA
[/
Bonsoir,

alors voici mon fichier.
en fonctions des 3 critères en cellule b10;a11 et b11si ces 3 critères sont réunis dans le tableau a1:j8 alors ma cellule b12 doit être égale à D2; b13 doit être égal à e2 et ainsi de suite... en espérant que se soit un peu plus clair...
 

Pièces jointes

  • Planning tec.xlsx
    9.9 KB · Affichages: 5

Discussions similaires