XL 2013 Problemes av Calcul de durée

looky62

XLDnaute Nouveau
Bonjour,
Qui peut m'aider sur mon pb, je souhaite soustraire les 2 cellules A et B mais comme une cellule contient des centiemes de secondes ça me renvoie une erreur , j'ai tenté plusieurs technique sans résultat si qq un peut m'aider ( les centiemes ne m'interesse pas dans mon calcul)

mon résultat en colonne E et F parfois B est vide !et A et B sont le meme jour et là c'est une durée en heure ou minute sec attendu
En plus pour couronner le tout A ou B peut avoir des centiemes en plus et parfois non!!
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour.
Pour supprimer les centièmes de secondes d'une valeur en A1 :
VB:
=ENT(A1*86400)/86400
86400 = 24 (heures) *60 (minutes) +60 (secondes)
Toujours pas de réponse à ma proposition sur l'autre fil qui ressemble à celui-ci. Vous avez "perdu le fil" ?
Indiquez comment les différents délais sont calculés, sans calculs d'apothicaire intermédiaires, et nous vous ferons une proposition.
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,

Une proposition en pj.
Le problème venait non pas des centièmes de secondes (ce n'est qu'une valeur numérique) mais plutôt que vous voulez dans la même cellule que soient affichées des valeurs dans deux formats différents (durée en hh:mm:ss et nb de jours en décimal)
 

Fichiers joints

Efgé

XLDnaute Barbatruc
Bonjour looky62, Salut Patrick :)
@ Patrick
J'ai testé ton dernier fichier sous 2007, 2016 et 365.
Quand je copie la formule =C2-A2 en $F$2 j'ai : 1035130
Si je tente de modifier la formule en $E2: pareille/la même chose....
C Koi le problème :D

Cordialement
 

looky62

XLDnaute Nouveau
Bonjour le fil, Salut Patrick :)

Voir la pièce jointe 1035152

Cordialement
Hello
Bonjour looky62, Salut Patrick :)
@ Patrick
J'ai testé ton dernier fichier sous 2007, 2016 et 365.
Quand je copie la formule =C2-A2 e$F$2 j'ai : Voir la pièce jointe 1035130
Si je tente de modifier la formule en $E2: pareille/la même chose....
C Koi le problème :D

Cordialement
Re,

Une proposition en pj.
Le problème venait non pas des centièmes de secondes (ce n'est qu'une valeur numérique) mais plutôt que vous voulez dans la même cellule que soient affichées des valeurs dans deux formats différents (durée en hh:mm:ss et nb de jours en décimal)
Bonjour Patrick ,
Merci pour ta proposition mais malheureusement la cellule m'affiche que des horaires, j'aimerai avoir durée en hh:min: sec et nombre de jours faut il que je recrée une colonne pr obtenir le nbre de jours éventuellement
Merci de votre aide je galere trop avec ce probleme
 

Efgé

XLDnaute Barbatruc
Bonjour le fil

Avec ce que j'ai compris et en remettant une virgule et un format de date compatible avec ma version.
Le résultat est un nombre, présenté suivant la situation en HH:MM:SS ou nombre de jours avec un format de cellule personalisé:
VB:
[<1]hh:mm:ss;[<2]"1 jour";# ###" Jours"
Cordialement
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour looky62, Victor21 :), Efgé :),

Principalement pour saluer mais camarades de jeu et pour le cas ou en reprenant la formule de victor21

=SI(ESTVIDE(C5);"";SI(C5-B5<1;TEXTE(C5-B5;"hh:mm:ss");TEXTE(NB.JOURS.OUVRES(B5;C5)&" Jours "&TEXTE(MOD(C5-B5;1);"hh:mm:ss");"#0")))

en cellule E5 du fichier exemple cette formule va afficher "16 jours 18:01:04"

Cordialement
 

Efgé

XLDnaute Barbatruc
Re au fil, Bonjour Jocelyn :)
Une version raccourcie de la formule de Jocelyn/Patick ?
=SI(ESTVIDE(C5);"";SI(C5-B5>1;TEXTE(ENT(C5-B5)&" Jours ";"#0");""))&TEXTE(MOD(C5-B5;1);"hh:mm:ss")
Cordialement
 
Dernière édition:

looky62

XLDnaute Nouveau
Re au fil, Bonjour Jocelyn :)
Une version raccourcie de la formule de Jocelyn/Patick ?
=SI(ESTVIDE(C5);"";SI(C5-B5>1;TEXTE(ENT(C5-B5)&" Jours ";"#0");""))&TEXTE(MOD(C5-B5;1);"hh:mm:ss")
Cordialement
Merci les Garçon mais
J'ai testé les 2 formules de Jocelyn et Efgé , et cela me donne en retour #valeurs ci joint le fichier, je suis perdue, je désespère avec cette problématique d'heures et de jours
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
re

je suis reparti de la formule de l'ami Efgé plus courte, je pense que le problème de valeur vient du point dans les cellules des colonnes B et C pour tester j'ai modifiées la formule pour quelle change le . en ,

Test et dis nous

Cordialement
 

Fichiers joints

Efgé

XLDnaute Barbatruc
Re
Bha oui….
Depuis longtemps nous parlons du séparateur décimal...
Il faut remplacer le point par une virgule.
Ca rallonge ma version:
VB:
=SI(ESTVIDE(SUBSTITUE(C5;".";","));"";SI(SUBSTITUE(C5;".";",")-SUBSTITUE(B5;".";",")>1;TEXTE(ENT(SUBSTITUE(C5;".";",")-SUBSTITUE(B5;".";","))&" Jours ";"#0");""))&TEXTE(MOD(SUBSTITUE(C5;".";",")-SUBSTITUE(B5;".";",");1);"hh:mm:ss")
Sinon, sans la précision de l'heure en plus du nombre de jours, il y aussi ma version avec format de cellule personnalisé dans le fichier joint.
A toi de voir
Cordialement

EDIT @Jocelyn : J'ai été un peu long dans ma réponse
:D
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour looky62, hello les amis,

A votre place les amis je donnerais une solution pour le cas où looky62 serait sur une version US avec le point comme séparateur décimal.

A+
 

Efgé

XLDnaute Barbatruc
Bonjour à toutes et tous
[…]mais malheureusement la cellule m'affiche que des horaires, j'aimerai avoir durée en hh:min: sec […]
Je pense que le problème ne viens pas du format horaire.

A mon idée, les date/heures proviennent d'une extraction avec un point comme séparateur, alors qua localisation de looky62 est la virgule.

Cordialement
 

Discussions similaires


Haut Bas