1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

problème avec datedif et cellule vide

Discussion dans 'Forum Excel' démarrée par rh.finances, 4 Décembre 2018.

  1. rh.finances

    rh.finances XLDnaute Junior

    Inscrit depuis le :
    12 Juillet 2009
    Messages :
    68
    "J'aime" reçus :
    0
    Travail/Loisirs :
    DRHF
    Habite à:
    Rouen
    Utilise:
    Excel 2016 (PC)
    Bonjour à tous les colistiers,

    j'ai l'habitude de travailler sur pas mal de formule sur Excel mais là, j'avoue que je bute totalement sur un problème depuis plus de 2 heures.

    dans le fichier joint, en cellule C12, j'ai une formule comprenant des SI imbriqués et la formule DATEDIF.
    toutefois, cette formule ne fonctionne pas (j'ai l'erreur #NOMBRE) et je pense que l'erreur vient de ma 2ème ligne de commande rédigée comme suit :
    SI(ET($C$6=$N$1;C7<>"";DATEDIF(C4;C7;"m")<=DONNEES!$B$3);"non";

    pour moi, la formule est correcte et je n'arrive pas à comprendre ce qui peut patiner :(.

    aussi, si quelqu'un aurait une idée et/ou une solution à ce problème, je serais volontiers preneur !!

    d'avance, merci à vous tou(te)s pour votre contribution.

    Alex
     

    Pièces jointes:

  2. Chargement...

    Discussions similaires - problème datedif cellule Forum Date
    Problème datedif format cellule Forum Excel 25 Février 2009
    XL 2013 [Résolu] problème Formule avec datedif Forum Excel 23 Mars 2017
    [RESOLU] - Problème DATEDIF Forum Excel 6 Avril 2015
    Problème datedif Forum Excel 26 Novembre 2013
    Problème Datedif Forum Excel 2 Mai 2010

  3. mdo100

    mdo100 XLDnaute Occasionnel

    Inscrit depuis le :
    29 Juin 2014
    Messages :
    246
    "J'aime" reçus :
    12
    Bonsoir,

    A tester en "C12"
    Code (Text):
    =SIERREUR(SI(OU(C4="";C5="");"";
    SI(ET($C$6=$N$1;C7<>"";DATEDIF(C4;C7;"m")<=DONNEES!$B$3);"non";
    SI(ET($C$6=$N$1;C7="";DATEDIF(C4;C5;"m")<=DONNEES!$B$3);"non";
    "oui")));0)
    Cordialement.
     
  4. djidji59430

    djidji59430 XLDnaute Accro

    Inscrit depuis le :
    3 Février 2014
    Messages :
    1449
    "J'aime" reçus :
    126
    Sexe :
    Masculin
    Habite à:
    Fort-Mardyck
    Utilise:
    Excel 2016 (PC)
    Bonjour,

    une autre :
    SI(ET($C$6=$N$1;C7<>"";sierreur(DATEDIF(C4;C7;"m");0)<=DONNEES!$B$3);"non";etc...

    Crdlmt
     
  5. rh.finances

    rh.finances XLDnaute Junior

    Inscrit depuis le :
    12 Juillet 2009
    Messages :
    68
    "J'aime" reçus :
    0
    Travail/Loisirs :
    DRHF
    Habite à:
    Rouen
    Utilise:
    Excel 2016 (PC)
    Bonsoir Mdo et Djidji,

    avec la fonction sierreur, tout est résolu !!
    un grand merci à vous !! sans votre aide, j'aurais jamais trouvé !

    Alex
     

Partager cette page