problème avec datedif et cellule vide

rh.finances

XLDnaute Junior
Bonjour à tous les colistiers,

j'ai l'habitude de travailler sur pas mal de formule sur Excel mais là, j'avoue que je bute totalement sur un problème depuis plus de 2 heures.

dans le fichier joint, en cellule C12, j'ai une formule comprenant des SI imbriqués et la formule DATEDIF.
toutefois, cette formule ne fonctionne pas (j'ai l'erreur #NOMBRE) et je pense que l'erreur vient de ma 2ème ligne de commande rédigée comme suit :
SI(ET($C$6=$N$1;C7<>"";DATEDIF(C4;C7;"m")<=DONNEES!$B$3);"non";

pour moi, la formule est correcte et je n'arrive pas à comprendre ce qui peut patiner :(.

aussi, si quelqu'un aurait une idée et/ou une solution à ce problème, je serais volontiers preneur !!

d'avance, merci à vous tou(te)s pour votre contribution.

Alex
 

Fichiers joints

mdo100

XLDnaute Occasionnel
Bonsoir,

A tester en "C12"
Code:
=SIERREUR(SI(OU(C4="";C5="");"";
SI(ET($C$6=$N$1;C7<>"";DATEDIF(C4;C7;"m")<=DONNEES!$B$3);"non";
SI(ET($C$6=$N$1;C7="";DATEDIF(C4;C5;"m")<=DONNEES!$B$3);"non";
"oui")));0)
Cordialement.
 

rh.finances

XLDnaute Junior
Bonsoir Mdo et Djidji,

avec la fonction sierreur, tout est résolu !!
un grand merci à vous !! sans votre aide, j'aurais jamais trouvé !

Alex
 

Discussions similaires


Haut Bas