XL 2016 Formule matricielle

pad01

XLDnaute Occasionnel
Bonjour le Forum,
Je souhaiterai récupérer l'horaire de début et de fin en fonction de la date et d'un nom.
La plage horaire (base de données) est dans la feuille "Mois actuel" et les données récupérées par nom seront sur la feuille "Recap individuelle".
Je suis preneur de toute solution. Les essais que j'ai fait, étaient avec une formule matricielle mais sans succès...
Je vous joins un fichier pour exemple.
Merci de votre aide.
Bien cordialement
Pad
 

Pièces jointes

  • Horaires Pad.xlsx
    67.3 KB · Affichages: 17

Rouge

XLDnaute Impliqué
Bonjour,

Formules non matricielles:

en B12:
=INDEX('Mois actuel'!$A$3:$Z$35;EQUIV($A12;'Mois actuel'!$B$3:$B$35;0);EQUIV($C$6;'Mois actuel'!$3:$3;0))

En C12:
=INDEX('Mois actuel'!$A$3:$Z$35;EQUIV($A12;'Mois actuel'!$B$3:$B$35;0);EQUIV($C$6;'Mois actuel'!$3:$3;0)+1)

Cdlt
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Pad,
En PJ un essai où j'ai préféré Index Equiv qui me semblait plus pertinent :
VB:
=SIERREUR(INDEX('Mois actuel'!$A$1:$Z$100;EQUIV($A12;'Mois actuel'!$B:$B;0);EQUIV($C$6;'Mois actuel'!$3:$3;0));"")
 

Pièces jointes

  • Horaires Pad.xlsx
    67.9 KB · Affichages: 7

pad01

XLDnaute Occasionnel
Bonjour le Forum,
Bonjour Rouge et Sylvanu
Merci à tous les deux pour votre aide. Les deux solutions répondent exactement à ma demande.
J'étais parti sur une mauvaise piste puisque une formule était suffisante.
Je vais regarder de plus près vos formules afin de m'améliorer.
Encore un grand merci à Rouge et Sylvanu pour l'aide apportée.
Bien cordialement
Pad
 

Discussions similaires

Haut Bas