[xls03] Compter les heures après 22h !

taltos

XLDnaute Nouveau
Bonjour a tous,

voila mon probleme, j'espere que vous pourrez m'aider !

j'ai dans un classeur un cellule ou je rentre l'heure de début de réunion ex 20:30

et une autre au je rentre l'heure de fin 23:30 ou 01:00

je doit a la fois extraire la durée de la réunion ( ça, ça va)
Mais surtout déterminer le temps au-delà de 22h00 ! et là, je bloque !

auriez vous une solution a me proposer ?

(évidement l'heure de début est libre et l'heure de fin peut être après minuit (ou pas) il n'y a que le 22h qui soit fixe

Merci vraiment de votre aide !

T.
 

tototiti2008

XLDnaute Barbatruc
Re : [xls03] Compter les heures après 22h !

Bonjour taltos,

le temps au-delà de 22h, ça doit donner ça :

=SI(C4<22/24;C4+2/24;C4-22/24)

avec C4 l'heure de fin

Edit : évidement, si 22:00 est variable et qu'il est dans la cellule D4 par exempe, ça donne plutôt :

Code:
=SI(C4<D4;C4+1-D4;C4-D4)
tout ça part du principe que tes réunions durent moins de 24:00 :)
 
Dernière édition:

Catrice

XLDnaute Barbatruc
Re : [xls03] Compter les heures après 22h !

Bonjour à tous,

La formule de Tototiti dans le fichier joint et une formule dans le meme esprit pour calculer la duree totale pour les reunions apres minuit.

=SI(C5>C4;C5-C4;C5+1-C4)
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Re : [xls03] Compter les heures après 22h !

Bonjour taltos, salut tototiti,

Une autre solution :

en A1 : heure début
en B1 : heure fin

en C1, cette formule :

Code:
=MOD(B1-MAX(22/24;A1);1)
A tester quand même

@+

Edit : Salut Catrice :)

@+
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas