Validation de données

amadeus22

XLDnaute Nouveau
Bonjour,

dans le fichier ci-joint je cherche, lorsque je crée une réservation papier pour la production,
à avoir un message si le stock se trouve inférieur à la quantité disponible.

je joins le fichier.

Un papier correspond à un fournisseur
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Bonjour,
Un petit essai en pj sur une seule ligne avec un stock manuel (les formules font appel à des lignes supprimées je crois) : juste pour vérifier si je t'ai bien compris.
Je me demande s'il ne faudrait pas utiliser une date du stock plutôt que prendre la dernière ligne de stock concernant le papier.
Si ça te va on pourra calculer la zone de recherche à partir des éléments de la feuille mouvement et mettre la formule dans la validation de données
Cordialement
 

Fichiers joints

amadeus22

XLDnaute Nouveau
bonjour,
j'ai réactualisé le fichier.
Effectivement l'idée est de mettre la formule ensuite en validation de donnée.
Sachant que si la quantité saisie en sortie met le stock
en négatif, il me faudra effectuer une mise en production pour compléter ma commande.

J'ai modifié le fichier. Le 1er jet n'était pas vraiment propre

Idéalement, la sortie de stock se mettrait en couleur rouge par exemple dès lors
que le stock passe en négatif.
 

Fichiers joints

amadeus22

XLDnaute Nouveau
bonsoir,

je l'ai légèrement modifié pour arriver à mes fins.
Le résultat est bien celui que je recherche
Je mets en pièce jointe le fichier pour que tu puisse voir ce que je cherche exactement.

Merci du temps que tu m'as consacré /

comment as tu créé E4 dans la formule =SI(F4="Sortie";RECHERCHEV(G4;INDIRECT(E4&"!$B$4:$F$10");5;FAUX)<0;"") ?

ca correspond à l'ensemble des feuilles ?
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Bonjour,
La fonction INDIRECT permet de créer une référence (plage) à partir de texte.
J'ai écrit une fois la formule pour une feuille :
=SI(F4="Sortie";RECHERCHEV(G4;Client_1!$B$4:$F$10;5;FAUX)<0;"")
puis j'ai remplacé la plage Client_1!$B$4:$F$10 par INDIRECT(E4&"!$B$4:$F$10")
on utilise donc la valeur indiquée en E4 pour spécifier la feuille et on utilise la même plage !$B$4:$F$10 pour toutes les feuilles.

Cordialement
 

Discussions similaires


Haut Bas