XL 2010 Supprimer le vide dans une liste déroulante

riton00

XLDnaute Impliqué
Bonsoir à tous,

Actuellement lorsque je sélectionne au moins 1 nom dans les cellules C5,C10,C15,F5,F10,F15 j'obtiens un vide en début de liste ainsi qu'à la fin de la liste déroulante
quelle serait l'astuce pour éviter ce vide!

Merci de votre aide

Slts
 

Fichiers joints

riton00

XLDnaute Impliqué
Re herve62, le forum

Simple oui et non puisque...... lorsque je remplie une à une les listes déroulantes suivant ton conseil, lorsque j'arrive à la troisième liste déroulante l'ascenseur se trouve tout en bas de la liste avec un premier espace vide, puis arrivé à la quatrième liste déroulante l'ascenseur se trouve toujours tout en bas avec deux espaces vide ainsi de suite. Alors que dans ma demande au post#1 j'ai bien spécifier que je voudrais éviter les espaces vides en haut et en bas.

Merci

Slts
 

riton00

XLDnaute Impliqué
Bonjour mapomme, le forum

Super! c'est net, précis et conforme à ma demande, merci beaucoup de votre implication.

Cordialement

Slts
 

patricktoulon

XLDnaute Barbatruc
bonjour a tous
excusez moi de faire une demande ici mais le sujet m’intéresse
je procède pas tout a fait de la même manière bien qu'il y ai des ressemblances
mais j'ai un soucis avec la liste restante en orange
des le premier retiré j'ai un zéro que je ne peut éviter a la fin des restants ( il y en a qu'un les autres restent vides au fur et a mesure)
quelqu'un sait comment faire
help!! @mapomme ;)
 

Fichiers joints

riton00

XLDnaute Impliqué
Bonsoir, patricktoulon, le forum

Tu peux utiliser un format de cellule personnalisé sur ta plage F9:F30
VB:
0;-0;;@
Slts
 

patricktoulon

XLDnaute Barbatruc
BONSOIR ritton00
non je veux du vrai vide pour les sauter dans la liste de validation
j'ai fait comme ca c'est pas beau mais bon
=SI(SIERREUR(INDEX(A2:A23; EQUIV(0; NB.SI(F$2:F8; A2:A23);0));"")=0;"";SIERREUR(INDEX(A2:A23; EQUIV(0; NB.SI(F$2:F8; A2:A23);0));""))
mais a final j'ai quand même le blanc dand la Ldv et on a un soucis avec le debut et la fin qui est decalé avec pour la Ldv
=DECALER($F$4;4;0;NB.SI($F$7:$F$100;"><");1)
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonsoir @patricktoulon ;), à tous,


Formule matricielle en F9 à tirer vers le bas :
VB:
=SI(NB.SI(F$2:F8;"><")-1=NBVAL(A$2:A$23);"";INDEX(A2:A23; EQUIV(0; NB.SI(F$2:F8; A2:A23);0)))
Voir le fichier en retour. Le nom de la liste de validation est maListe de définition =DECALER(A!$F$9;0;0;NB.SI(A!$F$9:$F$30;"><");1)
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas