XL 2016 Somme selon des critères par ligne

Rabeto

XLDnaute Junior
Bonjour,

Je souhaite trouver la somme des valeurs de la colonne Durée pour chaque ligne, pour chaque mois.
Avec un seul critère, j'arrive à le trouver avec la formule =somme.si(....) mais au delà de 2 critères ça me donne toujours erreur.
 

Pièces jointes

  • Somme.xlsx
    12.3 KB · Affichages: 5
Solution
Bonjour à tous,

Un exemple avec la fonction "decaler" mais cela est peut-être plus difficile à comprendre.
VB:
=SOMMEPROD(--((MOIS(DECALER($D$3;-1;1;;$C$1))=MOIS(1&B$3))*ESTNUM(DECALER($D4;;4;;$C$1)));DECALER($D4;;4;;$C$1))

JHA

JHA

XLDnaute Barbatruc
Bonjour à tous,

La formule pour calculer la fin de période est à revoir.
Manque aussi les durées pour CM CP, etc..
A essayer
VB:
=SOMMEPROD(($E$1:$Y$1=B$3)*(ESTNUM($H4:$AB4));$H4:$AB4)

JHA
 

Pièces jointes

  • Somme.xlsx
    13.6 KB · Affichages: 1

vgendron

XLDnaute Barbatruc
Bonjour

Un essai par macro
note: Dans ton fichier, les deux derniers jours de septembre sont notés "Octobre" ==> Erreur: la formule n'était pas recopiée

pour l'exemple, j'ai corrigé et ajouté un jour en octobre
en B3 et C3: j'ai changé le contenu pour avoir une date et modifié le format pour toujours afficher le mois complet
 

Pièces jointes

  • Somme.xlsm
    22.9 KB · Affichages: 1

Rabeto

XLDnaute Junior
Merci à tous,

La réponse de JHA semble être la clé, mais j'essai de trouver les explications de la formule car je ne comprends pas beaucoup,
Si j'étends la selection, ça me donne erreur. (Pourquoi la sélection du mois s'arrête sur la colonne Y ?)

@natorp : trouver la somme des heures dans chaque colonne Durée pour chaque ligne, pour chaque mois.
Donc les critères sont : le mois, critères Durée
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Un exemple avec la fonction "decaler" mais cela est peut-être plus difficile à comprendre.
VB:
=SOMMEPROD(--((MOIS(DECALER($D$3;-1;1;;$C$1))=MOIS(1&B$3))*ESTNUM(DECALER($D4;;4;;$C$1)));DECALER($D4;;4;;$C$1))

JHA
 

Pièces jointes

  • Somme ter.xlsx
    16 KB · Affichages: 2

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Rabeto, natorp, JHA, vgendron,

Principalement pour saluer mes camarades de jeu :)

Et accessoirement proposer une formule plus courte a mettre en B4 du fichier exemple de JHA et a étirer vers le la droite et le bas

VB:
=SOMMEPROD(($E$1:$AO$1=B$3)*(ESTNUM(H4:AR4));H4:AR4)

Cordialement
 

Discussions similaires

Réponses
8
Affichages
322

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
290 754
Messages
1 910 207
Membres
176 538
dernier inscrit
Charlydebutant
Haut Bas