XL 2016 Somme selon des critères par ligne

Rabeto

XLDnaute Occasionnel
Bonjour,

Je souhaite trouver la somme des valeurs de la colonne Durée pour chaque ligne, pour chaque mois.
Avec un seul critère, j'arrive à le trouver avec la formule =somme.si(....) mais au delà de 2 critères ça me donne toujours erreur.
 

Pièces jointes

  • Somme.xlsx
    12.3 KB · Affichages: 8
Solution
Bonjour à tous,

Un exemple avec la fonction "decaler" mais cela est peut-être plus difficile à comprendre.
VB:
=SOMMEPROD(--((MOIS(DECALER($D$3;-1;1;;$C$1))=MOIS(1&B$3))*ESTNUM(DECALER($D4;;4;;$C$1)));DECALER($D4;;4;;$C$1))

JHA

JHA

XLDnaute Barbatruc
Bonjour à tous,

Le 1er septembre 2021 est la semaine 35
Le 6 septembre 2021 est la semaine 36

=NO.SEMAINE("01/09/2021";21) = 35
=NO.SEMAINE.ISO("01/09/2021") = 35

seule la valeur 21 permet de retourner le numéro de semaine selon la norme ISO 8601.

JHA
 

Rabeto

XLDnaute Occasionnel
Bonjour à tous,

Un exemple avec la fonction "decaler" mais cela est peut-être plus difficile à comprendre.
VB:
=SOMMEPROD(--((MOIS(DECALER($D$3;-1;1;;$C$1))=MOIS(1&B$3))*ESTNUM(DECALER($D4;;4;;$C$1)));DECALER($D4;;4;;$C$1))

JHA
Bonjour @JHA

Bonne année à tous, meilleurs vœux :)

Je reviens un peu sur cette discussion car si je mets le mois Janvier, ça me donne des résultats que je ne comprends pas,
Prenant l'exemple du fichier, si je change le mois en janvier, ça me donne des résultats alors qu'il n'y a pas de résultats Janvier dans le tableau.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

J'ai modifié la formule en "C4" pour ne prendre que les colonnes des mois.
VB:
=SOMMEPROD(--((MOIS(DECALER($D$3;-1;1;;$C$1))=MOIS(1&C$3))*(MOD(COLONNE(DECALER($D$3;-1;1;;$C$1))-4;4)=$D$1)*ESTNUM(DECALER($D4;;4;;$C$1)));DECALER($D4;;4;;$C$1))

JHA
 

Pièces jointes

  • Somme ter (3).xlsx
    16.3 KB · Affichages: 3
  • Somme.xlsx
    12.8 KB · Affichages: 3

Discussions similaires

Réponses
6
Affichages
143

Statistiques des forums

Discussions
294 039
Messages
1 935 781
Membres
187 443
dernier inscrit
Sylviestl