[Résolu] Test de continuité d'une liste numérique avec la fonction SI

Verba_Tim

XLDnaute Occasionnel
Bonjour le fil! :)

J'ai une liste numérique de ce genre dans ma colonne A:
256
257
258
259
260
262
263
...

Je souhaite vérifier que je n'ai pas oublié de numéro. Pour cela, dans la colonne B, j'ai tenté d'insérer une bête formule SI de la façon suivante:

=SI(Nb(A2)=Nb(A1+1); 1, 0)

Ainsi, en théorie, si A2 est plus grand que A1 de une unité, B1 affiche 1, si non 0.

Sauf! Que Excel me rempli toute ma colonne de 0...

Je me creuse la tête et pense avoir oublié quelque chose...

J'ai vérifié le format qui est bien en nombre... je ne sais plus quoi faire x)

Help!

Merci d'avance :)


Verba_Tim
 
Dernière édition:

Victor21

XLDnaute Barbatruc
Supporter XLD
Re : Test de continuité d'une liste numérique avec la fonction SI

Bonjour.

Avez-vous eu la curiosité de regarder l'aide sur NB ?
Essayez =A2=A1+1 qui renverra faux si A2 n'est pas égal à A1+1
 

Verba_Tim

XLDnaute Occasionnel
Re : Test de continuité d'une liste numérique avec la fonction SI

Merci a vous deux pour votre réponse si rapide... Mais malheureusement ce n'est pas encore ça ^^'

Je vous joins un fichier exemple.
 

Fichiers joints

CISCO

XLDnaute Barbatruc
Re : Test de continuité d'une liste numérique avec la fonction SI

Bonjour à tous

Tu peux faire avec
=1*A2=A1+1

@ plus
 

R@chid

XLDnaute Barbatruc
Re : Test de continuité d'une liste numérique avec la fonction SI

Bonjour @ tous,
Pour éviter l'erreur VALEUR en C2,
Code:
=A2+0=A3-1
@ + +
 

Verba_Tim

XLDnaute Occasionnel
Re : Test de continuité d'une liste numérique avec la fonction SI

C'est bon ça fonctionne!

Merci beaucoup :))

Verba_Tim :eek:
 

JHA

XLDnaute Barbatruc
Re : [Résolu] Test de continuité d'une liste numérique avec la fonction SI

Re,

pour la MFC

Code:
=(A2*1=$A$2+(LIGNE()-2))=FAUX
JHA
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas