XL 2013 remplir un tableau à partir d'une bdd

Bokat

XLDnaute Nouveau
Bonjour,

j'ai un tableau qui regroupe un certain nombre de caracteristiques pour des plateaux de bureaux ( cf ci dessous)

J'aimerai recuperer tous les info des lignes où la colonne "I" indique "vide"... et j'avoue que je ne sais pas du tout comment faire :)

Ci dessous les lettre et numeros indiquent les colonnes où sont mes infos dans la base de donnée

Merci par avance pour votre aide !

IBLMNOALAM
8​
1​
11​
12​
13​
14​
37​
38​
NomTypeEtageunité€/sqm
or €/u
 

bbb38

XLDnaute Accro
Bonjour Bokat, le forum,
Bienvenue sur ce forum.
Tu souhaites récupérer toutes les infos des lignes où la cellule de la colonne « I » est vide, mais pour les stockées sur quel support (une feuille du même classeur, dans un autre répertoire, sur une clé USB, etc…).
Si tu pouvais mettre un petit fichier exemple, avec seulement quelques lignes, sans données confidentielles, cela serait plus agréable pour essayer de d’apporter une solution.
Cordialement,
Bernard
 

Bokat

XLDnaute Nouveau
Bonjour Bokat, le forum,
Bienvenue sur ce forum.
Tu souhaites récupérer toutes les infos des lignes où la cellule de la colonne « I » est vide, mais pour les stockées sur quel support (une feuille du même classeur, dans un autre répertoire, sur une clé USB, etc…).
Si tu pouvais mettre un petit fichier exemple, avec seulement quelques lignes, sans données confidentielles, cela serait plus agréable pour essayer de d’apporter une solution.
Cordialement,
Bernard
Hello oui ce sera plus simple... J'envoie ça dans lheure
 

Bokat

XLDnaute Nouveau
Bonjour,
Effectivement plus simple avec un fichier.
Dans onglet Bdd, ma base de données, dans onglet TabBord, les caracteristiques que je veux afficher pour chacune des lignes ou est indiqué "VACANT"
Merci pour votre aide !
 

Pièces jointes

  • exemple.xlsm.xlsx
    166.3 KB · Affichages: 6

bbb38

XLDnaute Accro
Bonjour Bokat, le forum,
Sans vba, je pense que c’est possible, mais je suis nul en formules ou fonctions (et en VBA, j’ai de gros progrès à faire).
Sur le forum, il me semble avoir aperçu des formules qui devaient gérer ton problème, mais je ne me suis jamais attardé sur celles-ci.
J’espère qu’un de ces spécialistes pourra te répondre. J’essaierai d’effectuer des recherches en fin de semaine.
Cordialement,
Bernard
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je me suis servi des n° de colonne de la ligne 4
VB:
=SIERREUR(DECALER(Bdd!$A$9;PETITE.VALEUR(SI(Vacant=TabBord!$A$6;LIGNE(Vacant)-9);LIGNE(1:1));B$4);"")

JHA
 

Pièces jointes

  • exemple_v2.xlsx
    64.7 KB · Affichages: 4

Bokat

XLDnaute Nouveau
Bonjour à tous,

Je me suis servi des n° de colonne de la ligne 4
VB:
=SIERREUR(DECALER(Bdd!$A$9;PETITE.VALEUR(SI(Vacant=TabBord!$A$6;LIGNE(Vacant)-9);LIGNE(1:1));B$4);"")

JHA
Bonjour et merci beaucoup pour ta solution qui a l'air de fonctionner egalement !
En revanche est ce que je pourrais te demander un "pas à pas" pour pouvoir l'appliquer à un fichier de bdd externe ? ( fichier et onglet a preciser) et surtout comment l'appliquer... j'avoue que je ne sais meme plus appliquer une formule matricielle........... merci pour ton aide
 

bbb38

XLDnaute Accro
merci beaucoup ca à l'air de bien fonctionner ! En revanche etant plus que rookie sur le sujet... comment faire pour mettre un fichier externe en source pour la bdd ? (fichier et onglet a prevoir) Merci encore pour votre aide !
Bonjour Bokat, JHA, le forum,
Une solution avec ouverture des 2 fichiers.
Insérer les 2 fichiers ci-inclus dans un même répertoire, et ouvrir le fichier « Resultats »
Cordialement,
Bernard
P.S. Bonjour JHA, Toutes mes félicitations pour la formule.
 

Pièces jointes

  • Resultats.xlsm
    79.7 KB · Affichages: 0
  • Bases.xlsm
    75.3 KB · Affichages: 0
Haut Bas