Rechercher les valeurs #NA / #VALEUR ...

lucifer71

XLDnaute Nouveau
Bonjour à tous,

Je suis dans une impasse, et j'ai beau chercher, je ne vois pas de solution.
Je m'en tourne donc vers vous.

Ma question est simple:
J'ai une colonne A, qui contient des valeurs Alpha et des valeurs numériques.
Je cherche à avoir, en CASE B1, une formule qui m'indique si la colonne A possède des #N/A ou des #REF ou des #VALEUR
Bref, savoir en B1, en un coup d'œil, si ma colonne A possède des erreurs.

Je voudrais bien passer par un principe de recherchev ou index equiv, mais je n'arrive pas à trouver la bonne écriture de formule, ou je ne sais meme pas si c'est vraiment possible.

Je précise : Pas de macro (impératif)

Merci beaucoup pour votre aide.
Bonne journée.
 

lucifer71

XLDnaute Nouveau
Re : Rechercher les valeurs #NA / #VALEUR ...

Bonjour Cisco,

Le problème est qu'avec cette formule, tu cherche si tu as une erreur dans la CASE A1, alors que je cherche à savoir si je possède une erreur dans toute la colonne A.

Mais je me suis posé la question si une formule matricielle avec un ESTERREUR ne pourrait pas fonctionner ?

Merci en tout cas :)
 

CISCO

XLDnaute Barbatruc
Re : Rechercher les valeurs #NA / #VALEUR ...

Bonjour

Je n'avais pas compris que tu cherchais une seule formule permettant de controler toute une plage.

Peut être avec, pour la plage A1:A4
Code:
=SOMME(SI(ESTERREUR(A1:A4);1;0))
en matriciel.

@plus
 

lucifer71

XLDnaute Nouveau
Re : Rechercher les valeurs #NA / #VALEUR ...

C'est parfait, tout fonctionne !

Merci beaucoup pour cette aide éclair !

Une excellente journée !
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas