XL 2016 Recherche valeurs a partir de 2 criteres

couverchel christophe

XLDnaute Nouveau
Bonjour à tous,

J'essaie de me dépatouiller avec un tableau et je n'arrive pas à manier les fonctions index et equiv, et j'ai l'impression que ce n'est pas celles ci que je dois utiliser. Le fait qu'un de mes critères de recherche sont dans l’entête de mon tableau me fait m'arracher les cheveux (ah ben nan j'en ai plus déjà :) )

Dans la première feuille se trouve le tableau des données qui doivent me servir a remplir automatiquement la troisième feuille appelé 'plan'.

Le tableau de données a pour entête des dates et pour ligne des noms. Les données du tableau correspondent a des numéros de kiosque à réserver.

Sur la feuille 'plan', j'aimerais que le nom de la personne et le coût du kiosque soit automatiquement mise dans une cellule particulière en fonction de la date choisi qui est défini par une liste déroulante.

Sur le fichier joint j'ai mis des petites notes si c'est pas clair mes explications :)

J'ai créé un deuxième tableau ( feuille 1) avec l'agencement des données différentes, mais ca ne marche pas non plus.

Si vous avez une idée de comment faire je suis preneur :)

D'avance merci messieurs les pros des formules :)

Chrsitophe
 

Fichiers joints

couverchel christophe

XLDnaute Nouveau
Bonjour Victor21,

Tu as ete rapide comme l'eclair.

J'etais proche de ce que tu as fait, il me manquait un equiv et j'etais presque bon :)

Un gros merci à toi.
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour Christophe.

En D2 :
=SIERREUR(INDEX(Donnees!$C$2:$C$43;EQUIV('Plan '!E1;DECALER(Donnees!$D$2:$D$43;;EQUIV('Plan '!$X$1;Donnees!$E$1:$T$1;0));0));"")
et en E4 :
=SIERREUR(INDEX(Donnees!$D$2:$D$43;EQUIV('Plan '!E1;DECALER(Donnees!$D$2:$D$43;;EQUIV('Plan '!$X$1;Donnees!$E$1:$T$1;0));0));"")
Edit : Bonjour, jocelyn. J'étais là, mais caché ;) Et comment pourrai-je t'en vouloir ???
 

Fichiers joints

couverchel christophe

XLDnaute Nouveau
Bonjour à vous deux :)

Ne vous battez pas pour m'aider, meme si un combat dans la boue pourrait etre correct :)

Un gros merci, je vais tester vos deux solutions.
 

couverchel christophe

XLDnaute Nouveau
Bonjour à tous,

Je viens de voir ton tableau jocelyn, et il est parfait pour moi :)

Vous êtes adorable d'avoir si vite répondu à mon problème.

Christophe
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas