XL 2013 Récapitulatif sur plusieurs classeurs

fourezizou

XLDnaute Occasionnel
Bonjour,

je cherche une solution de mon problème.

le problème est comme suit :

J'ai 10 classeurs identique avec 100 feuil (identiques aussi) chaque classeurs se trouve sur un ordinateur.

ci-dessous les en-tête de chaque feuil

OrdreCodeDésignationN° LotDDPPPAQuantitéObs.Pivot

ma question est : comment je peut faire une récapitulatif sur un seuil feuil somme de (Quantité) ; critère (Ordre)

Je vous remercie pour vos réponse.
 

Staple1600

XLDnaute Barbatruc
Bonjour le fil, fourezizou

fourezizou
Il n'y a de nombreux exemples similaires à ta question dans les archives du forum
1) Tu peux déjà regarder en bas de la page dans les discussions similaires
(on y trouve par exemple cette discussion)

2) Tu peux aussi approfondir les rechercher en utilisant le moteur de recherche du forum
 

fourezizou

XLDnaute Occasionnel
Bonjour
@Staple1600

Merci pour vous réponse

J’ai fait des recherches plusieurs fois mais je n’arrive pas à résoudre mon problème

  • J’ai essayé avec power pivot mais c’est très lent (il faut lie tous les table)
  • Avec formule matricielle :
  • nomFeuilles=STXT(ALEA()*0&LIRE.CLASSEUR(1);2;50)
  • NomFeuil A1=SI(LIGNE()>NBVAL(nomFeuilles);"";STXT(INDEX(nomFeuilles;LIGNE());CHERCHE("]";INDEX(nomFeuilles;LIGNE()))+1;30))
  • Plage1=NomFeuil!$A$1:$A$77
  • Formule resultat sur la feuil de recap (colonne Quantité) H2=
    =SOMMEPROD(SOMME.SI(INDIRECT(Plage1&"!i2:i15000");I2;INDIRECT(Plage1&"!H2:H15000")))
    il m'affiche #ref
 

Roblochon

XLDnaute Accro
Bonjour,

ma question est : comment je peut faire une récapitulatif sur un seuil feuil somme de (Quantité) ; critère (Ordre)
Pourtant dans votre exemple, votre formule semble vouloir sommer en fonction de PIVOT (qui semblent être les même).
Ce qui pourrait se faire (l'un comme l'autre), soit par TCD soit par power - QUERY (sans avoir à lier les tableaux, mais par UNION)
Si vous utiliser des sommeprod sur de telles quantités, vous aurez des ralentissements.

Dans le fichier joint, après suppression de pas mal de ligne pour ne pas dépasser la capacité des classeurs chargés sur xld,
une soluce par TCD multi sources et une soluce par Power Query et regroupement sur PIVOT uniquement.
Dans cette dernière les tables du classeurs sont filtrées pour union, par Commence par:Tableau231532

Cordialement
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas