XL 2010 Macro Excel 10...récupération d'un tableau sur site web

Alain3038

XLDnaute Nouveau
Bonjour
Merci avant tout de l'aide que vous pourriez m'apporter.

Il y a longtemps, je connaissais un petit peu, puis la retraite oblige, j'ai perdu.
Je suis sous windows10 avec excel 10.

J'aimerais récupérer le tableau des cours d'actions sur un site boursier.

j'ouvre le site, je tape mon identifiant, mon mot de passe, et je met sur l'écran du tableau en question.

je copie le tableau et le colle sur une feuille excel, pour le retravailler ensuite sur d'autres feuilles en liaison.(j'ai mis aussi une touche de raccourci dans la macro)

A la première utilisation, cela fonctionne, tant que le pc n'a pas été arrêté, c'est tout bon (il me semble), mais si je change de site entre temps ou si je ferme le pc, quand je redémarre et que je relance la macro, un message d'erreur s'affiche.

capture message erreur excel 10
Voici la macro en question:

Sub TRANSFERT()

'

' TRANSFERT Macro

' cours des actions
'
' Touche de raccourci du clavier: Ctrl+Shift+T
'
Range("A1").Select

"cette fonction s'affiche comme erreur en jaune"
ActiveSheet.PasteSpecial Format:="HTML", Link:=False, DisplayAsIcon:= _
False, NoHTMLFormatting:=True

Range("A11").Select

End Sub

J'ai créé la macro à l'aide de l'outil d'excel.

voila, j'espère avoir été clair dans mes explications.

Merci de votre aide car je n'arrive pas à trouver le problème.

cordialement
 

Rouge

XLDnaute Impliqué
Bonjour,

C'est un fonctionnement normal, si vous avez fait un copié et qu'entre temps vous avez fait une autre action autre que de coller ce que vous venez de copier, alors le presse-papiers est vidé de son contenu, donc il n'y a plus rien à coller, d'où le message d'erreur.
Avant cette ligne :
VB:
ActiveSheet.PasteSpecial Format:="HTML", Link:=False, DisplayAsIcon:= _
False, NoHTMLFormatting:=True
Ajoutez ceci:
Code:
on error resume next
Cdlt
 

job75

XLDnaute Barbatruc
Bonjour Alain3038, bienvenue sur XLD,

Il y a bug parce qu'il n'y a rien à coller : le presse-papiers est vide.

Pour avoir quelque chose dans le presse-papiers il faut copier quelque chose.

Salut Rouge, on s'est croisé, On Error Resume Next évite le message d'erreur qui est pourtant utile.

A+
 
Dernière édition:

Alain3038

XLDnaute Nouveau
Bonjour
merci de vous intéressez à mon problème.
j'ai copier le code : On Error Resume Next en dessous de la ligne qui s'affiche en jaune lors de l'exécution de la macro.
Mais, cela ne fonctionne pas, j'ai comme résultat"on error resume next qui s'affiche dans mon tableau.

Pourtant quand je crée la macro, je copie les données qui m'intéresse et en effet sur le code vba je ne le vois pas.
il faut préciser quand même, que je suis pas très fort.

Merci de votre aide.

cordialement
 

Alain3038

XLDnaute Nouveau
encore moi......
encore merci et désolé de t'importuner avec mes petit soucis.

Bon, j'ai changé la ligne de place.
le message n'apparait plus, mais par contre le tableau ne se met pas à jour.

La macro semble fonctionner, mais........?ne copie pas les données du site puisque le tableau reste vide.

Petite précision, je n'ai pas recréé la macro depuis le début, juste je l'exécute, sans passer par copier/coller d'excel, ce que je fait lorsque je crée cette macro.
Suis-je clair.........!

Nouvelle macro

Sub TRANSFERT()
'
' TRANSFERT Macro
'
' Touche de raccourci du clavier: Ctrl+Shift+T
'
On Error Resume Next
ActiveSheet.PasteSpecial Format:="HTML", Link:=False, DisplayAsIcon:= _
False, NoHTMLFormatting:=True

Range("A1").Select
End Sub

je sais que je suis un peu lourd avec mes "merci" mais c'est tellement sympa de bien vouloir m'aider.

cordialement
 

Alain3038

XLDnaute Nouveau
oui, le tableau représente des actions d'un portefeuille fictif, il y a 6 lignes.

Lorsque, je crée la macro, en démarrant d'excel, je sélectionne la zone à copier puis retourne sur excel et colle dans le tableau en question, les données récupérées.
là, c'est tout bon.....les données apparaissent et sont traitées par liaisons avec d'autres tableaux.

Là, où cela ne va plus, c'est lorsque je quitte soit le web, soit que je ferme excel.
Le fameux message qui apparaissait corrigé par ton aide n'apparait plus mais le reste non plus.

Par contre, il est vrai que je ne fait pas de de CTRL+C avant de lancer la macro; je pensais que la macro s'en chargeait.

Donc, si je comprend tout, je dois effectuer un CTRL+C sur la sélection de mon tableau WEB avant de lancer la macro.
Il n'y a pas de possibilité d'automatiser cette action....!

je fais le test et je reviens.

Merci
cordialement
 

Rouge

XLDnaute Impliqué
"Là, où cela ne va plus, c'est lorsque je quitte soit le web, soit que je ferme excel.
Le fameux message qui apparaissait corrigé par ton aide n'apparait plus mais le reste non plus.

Par contre, il est vrai que je ne fait pas de de CTRL+C avant de lancer la macro; je pensais que la macro s'en chargeait.

Donc, si je comprend tout, je dois effectuer un CTRL+C sur la sélection de mon tableau WEB avant de lancer la macro."


Bien sûr qu'il faut faire un copié ou CTRL + C avant de vouloir coller.
 

Discussions similaires

Haut Bas