XL 2016 fonction recherche avec plus grand que

phil77

XLDnaute Junior
bonjour a tous

j ai un classeur
avec en A1 vert
en A2 rouge
en a3 noir

en b1 100
en b2 200
en b3 300

je souhaiterais que excel puis me trouver le premier emplacement supérieur a 120 dans la plage B1:B3 par exemple et me reporter le contenu de la cellule de la meme ligne
dans mon exemple si je cherche quel est la valeur superieur a 120
il trouve B1 et affiche donc vert
tout en sachant que j avais pense a des SI imbriquer mais j aurais +- 600 lignes donc 400 cellules ou chercher

merci de votre aide
 

Fichiers joints

phil77

XLDnaute Junior
bonjour vmax01
merci pour la réponse
non en fait je souhaiterais qu excel me recherche dans la plage B1:B3
la première cellule qui pourrait contenir 120 ( désolé me suis mal exprime )
dans cet exemple c est la cellule B2 et qu il affiche rouge

si j avais ecrit recherche 225 il m aurait trouver b3 et afficher noir
 

job75

XLDnaute Barbatruc
Bonjour phil77, vmax01,

Si le tableau sources A:B est toujours trié par valeurs croissantes de la colonne B, entrez en D6 :
Code:
=INDEX(A:A;EQUIV(C6;B:B)+1)
A+
 

Fichiers joints

job75

XLDnaute Barbatruc
Re,

Si les valeurs en colonne B ne sont pas toujours triées on peut utiliser cette formule matricielle en D6 :
Code:
=SIERREUR(INDEX(A1:A1000;EQUIV(PETITE.VALEUR(SI(B1:B1000>C6;B1:B1000);1);B1:B1000;0));"")
à valider par les touches Ctrl+Maj+Entrée.

Fichier (2).

A+
 

Fichiers joints


Haut Bas