Extraire plusieurs données d'une colonne en fonction d'une recherche sur une ligne

DrStax

XLDnaute Nouveau
Bonjour, Bonsoir,

Je dois résoudre un problème qui me donne du fil à retordre malgré de multiples essais infructueux.
J'ai le tableau suivant (Qui en réalité comprend des centaines de colonnes et des milliers de ligne).
ARG et ARGC sont les titres. On dit que valeur CX est l'identifiant unique de ma ligne.

Je voudrais pouvoir à partir d'une recherche sur la valeur CX (Par exemple "Valeur C8") extraire les données ARGC 1 2 et 3 des colonne comportant un "X" sur ma ligne comportant la valeux CX. J'ai déjà essayer avec des INDEX et EQUIV mais je ne pense pas que cela soit adapter à ma demande.

Je sais comment identifier la ligne, ça il n'y a pas de problème, mais c'est surtout pour vérifier chaque colonne et ensuite en extraire les 3 première ligne si un "X" est présent qui est problématique.


ARG 1ARG 2ARG 3ARGC 1Valeur Col E1Valeur Col F1Valeur Col G1Valeur Col H1Valeur Col I1
ARGC 2Valeur Col E2Valeur Col F2Valeur Col G2Valeur Col H2Valeur Col I2
ARGC 3Valeur Col E3Valeur Col F3Valeur Col G3Valeur Col H3Valeur Col I3
Valeur A5Valeur BValeur C5
Valeur A6Valeur BValeur C6XX
Valeur A7Valeur BValeur C7
Valeur A8Valeur BValeur C8XX
Valeur A9Valeur BValeur C9
Valeur A10Valeur BValeur C10X

Pensez vous que cela soit faisable ? Est-ce vraiment très compliquer à réaliser ? Que me conseillez vous ?

Merci à tout le monde !
 

DrStax

XLDnaute Nouveau
Merci pour l'aide, mais ce n'est pas ce que j'ai besoin, je vais esseyer de mieux m'expliquer.

Si par exemple je tape dans la recheche la valeur "Valeur C6" par exemple le résultat que je recherche est le suivant :

Valeur Col F1Valeur Col F2Valeur Col F3
Valeur Col H1Valeur Col H2Valeur Col H3

Je sais pas si c'est plus clair. Donc les valeurs des colonnes ou se trouve un x sur la ligne de la "Valeur C6".

Il est possible que ce que je demande ne soit pas possible ^^
 

Dranreb

XLDnaute Barbatruc
Bonjour.
En A12 :
Code:
=EQUIV($M$2;$C$5:$C$10;0)
En B12 :
Code:
=EQUIV("*";INDEX($D$5:$I$10;$A$12;0);0)
En E12:G12 validé par Ctrl+Maj+Entrée :
Code:
=TRANSPOSE(INDEX($D$1:$I$3;0;$B12))
En B13 :
Code:
=SIERREUR(B12+EQUIV("*";DECALER($D$4;$A$12;B12;1;5-B12);0);"")
En E13:G13 validé par Ctrl+Maj+Entrée :
Code:
=SI($B13<>"";TRANSPOSE(INDEX($D$1:$I$3;0;$B13));"")
 

Discussions similaires


Haut Bas