Extraction une BDD en respectant deux conditions

Meloman

XLDnaute Occasionnel
Bonjour,Bonjour

je viens vous embêtez un petit peu ;) je suis confrontez à un petit problème de taille.

j'ai une base de donnée avec des noms et l’attribution de Bip chaque bip attribuer par nom respecte un emplacement bien précis (même si c'est pas marquer clairement dans la base de donnée)

Zone1
Zone2
Zone3

je incrémenter une liste sous condition permettant de récupérer les noms dans la bonne zone si ceux dernier est marquer BIP

je vous est mis un fichier joint avec un code couleur permettant je pense de mieux comprendre à recherche.

comment pourrais je faire svp pour arriver à mes fins

merci
 

Fichiers joints

Meloman

XLDnaute Occasionnel
Re : Extraction une BDD en respectant deux conditions

Bonsoir Rachid et merci pour ton aide c'est génial juste une question comment tu fais pour avoir col_Nom et Col_Atribut je sais pas ou aller pour le faire merci
 

R@chid

XLDnaute Barbatruc
Re : Extraction une BDD en respectant deux conditions

Re,
c'est dans le gestionnaire de noms que je les ai définis..
je peux toute fois te refaire la formule sans ces champs là si tu veux.
 

Meloman

XLDnaute Occasionnel
Re : Extraction une BDD en respectant deux conditions

Re Si c'est possible oui car il est vrai j'en ai pas une grande maitrise merci
 

R@chid

XLDnaute Barbatruc
Re : Extraction une BDD en respectant deux conditions

Re,
en F3 :
Code:
=SIERREUR(INDEX($A$2:$A$10;PETITE.VALEUR(SI(($A$2:$A$10<>"")*(DECALER($B$2:$B$10;COLONNES(Feuil1!$F:F)-1;)<>"");LIGNE(INDIRECT("1:"&LIGNES($A$2:$A$10))));LIGNES($3:3)));"")
@ valider par Ctrl+Shift+Enter
@ tirer vers le bas et vers la droite


@ + +
 

Meloman

XLDnaute Occasionnel
Re : Extraction une BDD en respectant deux conditions

Bonjour à toi et merci pour ton code qui fonctionne bien MAIS en fait si j'ai une autre valeur que Bip qui apparais il m'extrait aussi le nom sa c'est très embêtant si possible j'aimerais que la condition soit le mot Bip et non cellule vide svp merci
 

Meloman

XLDnaute Occasionnel
Re : Extraction une BDD en respectant deux conditions

J'ai essayer comme ceci
Code:
=SIERREUR(INDEX($A$2:$A$10;PETITE.VALEUR(SI(($A$2:$A$10="Bip")*(DECALER($B$2:$B$10;COLONNES(Feuil1!$F:F)-1;)="Bip");LIGNE(INDIRECT("1:"&LIGNES($A$2:$A$10))));LIGNES($3:4)));"")
mais sa fonctionne pas
 

R@chid

XLDnaute Barbatruc
Re : Extraction une BDD en respectant deux conditions

Bonjour,
désolé pour cette erreur dont j'ai pas fait attention, c'est pas comme ça que j'ai fait la première formule avec les noms de champs, alors en F3 :
Code:
=SIERREUR(INDEX($A$2:$A$10;PETITE.VALEUR(SI(($A$2:$A$10<>"")*(DECALER($B$2:$B$10;COLONNES(Feuil1!$F:F)-1;)="Bip");LIGNE(INDIRECT("1:"&LIGNES($A$2:$A$10))));LIGNES($3:3)));"")
@ valider par Ctrl+Shift+Enter
@ tirer vers le bas et vers la droite


@ + +
 

Meloman

XLDnaute Occasionnel
Re : Extraction une BDD en respectant deux conditions

Re bonjour grand merci à toi les testes fonctionne trés bien je vais donc l'appliquer au fichier réel mais je pense tout seras ok grace a tes grande compétence merci rachid
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas