Cumuls et extractions selon dates

Julie-F

XLDnaute Occasionnel
Bonsoir le forum,

Je ne parviens pas à trouver la formule conditionnelle adaptée.:(
J'ai un fichier comprenant 4 onglets. les 3 premiers onglets sont des bases de données par année.
Le dernier "Extract" comprenant un tableau dans lequel je souhaite collationner et sommer les données, selon les conditions, pour chacune des BD en fonction des dates définies. Or si cette période commence toujours au 1 janvier , le bornage de fin de période est modifiable selon les besoins.
Je sais que mon problème est abscons, aussi je joins un fichier en espérant que çà soit plus clair.

Merci d'avance à tous pour votre aide et vos conseils.
 

Fichiers joints

Julie-F

XLDnaute Occasionnel
Bonjour JHA

Merci beaucoup, çà fonctionne.
Serait-il possible d'avoir quelques explications quant aux formules utilisées afin de mieux les comprendre ?:oops:
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

pour cette formule

Code:
=SOMMEPROD((INDIRECT("'BD"&B$4&"'!$A$2:$A$30")>=DATE(B$4;1;1))*(INDIRECT("'BD"&B$4&"'!$A$2:$A$30")<=DATE(B$4;DROITE($D$2;2);GAUCHE($D$2;2)))*(INDIRECT("'BD"&B$4&"'!$F$2:$F$30")>=STXT($A5;4;2)*1)*(INDIRECT("'BD"&B$4&"'!$F$2:$F$30")<=DROITE($A5;2)*1))
la fonction indirect() permet de reconstituer le chemin des données à analyser ici 'BD2014'!$A$2 : $A$30
DATE(B$4;1;1) pour le 1/1/2014
DATE(B$4;DROITE($D$2;2);GAUCHE($D$2;2)) pour le 29/8/2014
STXT($A5;4;2)*1 pour rechercher la valeur 20 de la cellule $A5
DROITE($A5;2)*1 pour rechercher la valeur 30 de la cellule $A5

Si tu veux voir ce que fait la formule, tu cliques en "B5" puis tu choisis l'onglet formule/Evaluer la formule et tu cliques sur évaluer plusieurs fois.

JHA
 

Julie-F

XLDnaute Occasionnel
Cool !!
Merci beaucoup JHA pour ces explications
Je ne connaissais pas cette possibilité; Je crois que je vais l'adopter et pas uniquement pour ce fichier ;)

Bonne soirée à tous
 

Discussions similaires


Haut Bas