Compter le nombre de cellules entre 2 valeurs

A

Archi

Guest
je viens de penser à
=SI(ET($Y$4<=AUJOURDHUI();SOMME(AC7:AD7)<5);5-SOMME(AC7:AD7))*5

à vérifier
 
M

Monique

Guest
Bonjour,

Ce que tu dis me semble bon :
=SI(ET($Y$4<=AUJOURDHUI();SOMME(AC7:AD7)<5);5-SOMME(AC7:AD7))*5

Ou bien si on ne veut le résultat qu'après la date (après minuit) :
=SI(ET($Y$4<AUJOURDHUI();SOMME(AC7:AD7)<5);5-SOMME(AC7:AD7))*5
 
A

Archi

Guest
Bonjour Monique,

Je viens de me lancer dans un autre type de classement:
Le championnat des pilotes moto GP
J'ai fait une ébauche de classement
Peux tu jeter un oeil SVP

@+
 

Fichiers joints

M

Monique

Guest
Bonjour,

ça change, dis donc.

En H53 :
=SOMMEPROD((L50:AA50=Données!A$4:A$18)*Données!B$4:B$18)
que tu recopies vers le bas.
Je ne sais pas comment tu vas organiser ton classement par la suite, mais tu peux prévoir :
=SOMMEPROD((L50:AA50=Données!A$4:A$18)*Données!B$4:B$18)+LIGNE()/100000

Du coup, tu peux supprimer les colonnes D:S de ta feuilles "Données"

En K50 (c'est plus court) :
=SOMMEPROD((L50:AA50={1;2;3})*1)

En C50 et C51 : ne mets pas de format texte, si possible (je pense que tu y mettras une formule, par le suite).

Sinon, tu ne devrais pas donner à tes feuilles des noms si longs, avec espaces, chiffres et tout ce qu'il faut pour rallonger les formules.

C'est tout ce que j'ai vu de particulier.
 
M

Monique

Guest
Re,

J'ai oublié : tu peux utiliser le tableau L46:Z47 à la place de celui de la feuille "Données", mais tu n'auras le résultat que par une matricielle.
En H50 :
=SOMMEPROD((TRANSPOSE(L50:AA50)=L$47:Z$47)*L$46:Z$46)
Autant laisser dans une feuille à part tout ce qui est table de correspondances.
 
M

Monique

Guest
Re bis,

Suite
En J50 (plus court) :
=NB.SI(L50:AA50;"<>&NP")
 
A

Archi

Guest
Ok merci je vais voir ça

Autre chose,

dans le tableau C5:AA40
j'ai inséré une colonne en L pour compter les poles position en fonction de la plage M39:AB39
ça Donne en L7 par exemple

=SOMMEPROD((N39=D7)+(O39=D7)+(P39=D7)+(Q39=D7)+(R39=D7)+(S39=D7)+(T39=D7)+(U39=D7)+(V39=D7)+(W39=D7)+(X39=D7)+(Y39=D7)+(Z39=D7)+(AA39=D7)+(AB39=D7)+(AC39=D7)+(AD39=D7)+(AE39=D7)*1)

Prob, je n'utilise en plage M39:AB39 que les 4 premières lettres des noms
en D7:D36 ??
Comment faire ??
 
A

Archi

Guest
Marche pas ma formule, je suis en train de m'emméler avec INDEX EQUIV
 
A

Archi

Guest
je viens de trouver en L7
=NB.SI($M$39:$AB$39;INDEX($D$7:$D$36;0))

mais j'ai toujours un prob avec les abréviations de noms
 
M

Monique

Guest
Re,

Je n'ai plus les mêmes références que toi, parce que je ne sais pas où tu as inséré une colonne.

A la place de :
=SOMMEPROD((N39=STXT(D7;3;3))+(O39=STXT(D7;3;3))+(P39=STXT(D7;3;3))+(Q39=D7)+(R39=D7)+(S39=D7)+(T39=D7)+(U39=D7)+(V39=D7)+(W39=D7)+(X39=D7)+(Y39=D7)+(Z39=D7)+(AA39=D7)+(AB39=D7)+(AC39=D7)+(AD39=D7)+(AE39=D7)*1)
tu mets :
=SOMMEPROD((N39:AE39=STXT(D7:D36;3;3))*1)
Le premier 3 : tu démarres au 3è caractère.
Le deuxième 3 : tu prends 3 caractères.
Ce n'est pas les 4 premiers caractères que tu prends.

Index Equiv, c'est pour quelle raison ?
 
M

Monique

Guest
ou bien (ça dépend de ce que tu veux) :
=SOMMEPROD((L39:AA39=STXT(D7;3;3))*1)
 
A

Archi

Guest
bien ta formule
=SOMMEPROD((N39:AE39=STXT(D7:D36;3;3))*1)


cependant si je régle sur les 4ère lettres:
=SOMMEPROD((N39:AE39=STXT(D7:D36;1;4))*1)

la formule ne me donne plus les noms inférieur à 4 ??
j'ai des noms en trois ou deux lettres
 
A

Archi

Guest
je viens de bricoler
=SOMMEPROD(($N$39:$AE$39=STXT(D7;1;4))+($N$39:$AE$39=STXT(D7;1;3))+($N$39:$AE$39=STXT(D7;1;2))*1)

si tu as mieux, je suis preneur
 
M

Monique

Guest
Re,

= STXT ( cellules colonne D ; 1 ; 4 ) te donne :
V.RO, M.BI, T.UK, A.BA, C.CH, N.AB, D.KA, L.CA, Ke.R.
Et ce sont sont ces 4 caractères que tu devras taper dans les lignes 39 et 40
Ce n'est pas trop lisible, c'était mieux, tout à l'heure..

Pour les noms ayant moins de 4 caractères, il faudrait taper des espaces en plus, pour arriver à 4 caractères ! Ils ont bien un prénom, quand même ?
C'est une histoire de fou.
Sinon, STXT( x ; 1; 4 ) équivaut à GAUCHE( x ; 4 )
 
A

Archi

Guest
je vais prendre
=SOMMEPROD((N39:AE39=STXT(D7:D36;3;3))*1)
tu as raison, c'est plus simple

Merci pour tous
@+
 
M

Monique

Guest
Re,

Réponse à ton message de 19:18
Cette formule-ci, pour remplacer ()+()+() :
=SOMMEPROD(($N$39:$AE$39=GAUCHE(D7;{2;3;4}))*1)
 
M

Monique

Guest
Bonjour,

On peut prendre la valeur absolue.
EN F5 de la feuille "Données" :
=SI(Synthèse!F5>0;ABS(SUBSTITUE(SUBSTITUE(SUBSTITUE($D5;"NCF";100);"NC";100);"F";"")+LIGNE()/10000-SUBSTITUE(F$4;"NC";100)*0,999);LIGNE()/10000)
Mais ça n'arrange pas la situation de Grosse Stéphanie et je ne sais pas pourquoi.
C'est le 80F qui pose problème, pas les le NC ni le NCF.

Sinon, comme tu dis, on peut aussi se baser sur les points.
Pas du SommeProd, mais un index equiv de la colonne D dans le tableau de classement, moins l'index equiv de la ligne 4 dans ce même tableau.
Toujours en valeur absolue.
Et en mettant les 2 tableaux l'un en-dessous de l'autre pour ne pas avoir de formule conditionnelle du genre SI ( DROITE ( cellule ) ="F", tel tableau, sinon tel autre tableau.

Pour la formule de la feuille "Synthèse", je suis en panne.
 

Discussions similaires


Haut Bas