Compter le nombre de cellules entre 2 valeurs

B

Brigitte

Guest
Bonjour Archi,

Comme je vois là, tu es encore sur ton affaire.... Je vais suivre ca à la maison, là je suis au boulot, mais quel courage !!

J'espère que tu vas finir par trouver tout ce que tu veux.

Bonne journée
 
M

Monique

Guest
Bonjour,

Tu as plein d'ex aequo et, aussi, des ex aequo contre le même adversaire (tant qu'à faire, mais je ne sais pas si tu en auras)
On garde la ligne / 10000 et on ajoute le classement de l'adversaire / 1000
 

Fichiers joints

A

Archi

Guest
Nikel Monique, tous mes prob ont été résolu
Merci à toi et à Brigitte pour vos lumières

@+ pour de nouvelles aventures
 
A

Archi

Guest
j'ai crié victoire trop vite

Aprés réflexion,seul le classement adverse me paraît utile, mais je n'arrive pas à ôter la liaison S34
=SI(H34<1;"";INDEX(Z$5:Z$32;EQUIV(S34;Y$5:Y$32;0)))

d'autre part, le prob reste entier avec "NCF"
 
A

Archi

Guest
Bonjour Monique,

je me suis amusé à remettre le tableau à zéro, puis à insérer une valeur 1 en L30 et en M30

La réponse en W30 est de 75 au lieu de 40 ???
de même en S34 j'ai 25 au lieu de 60 ??
En faite, il fait l'addition les deux écarts (40+35) au lieu de prendre la plus élevé ???

que se passe t-il ???

Merci de m'en dire plus
 
M

Monique

Guest
Bonjour,

Depuis le début (pour moi, en tout cas), la formule de la colonne W n'est faite que pour un jeu gagné par joueur.
Je me souviens avoir pensé à ce que tu dis.
Malheureusement, je ne vois pas comment en sortir, sauf par un tableau intermédiaire (l'actuel, en fait)
et un autre qui ne donnerait que le max de chaque joueur.
 
A

Archi

Guest
Je crois aussi qu'il faut créer un tableau annexe

En faite, Brigitte était sur la bonne piste !!!

je me mets au boulot est je te rappelle
 
M

Monique

Guest
Re,

Pas besoin de tableau intermédiaire, en fin de compte.
Le principal de la formule : trouver le n° de la colonne située le plus à gauche
et contenant une valeur > 0.
Formule matricielle à valider par ctrl, maj et entrée.
Tu vérifieras.
 

Fichiers joints

A

Archi

Guest
Bonjour Monique,

Je n'est pas consulté ma messagerie hier soir (quelle erreur), donc je n'est pas lu ton dernier post,.... donc j'ai fait un tableau intermédiaire (pas grave)

Peux tu qu'en même jeter un oeil, ça peut toujours servir !!!

En créant ce tableau, je me suis posait d'autres questions !!!!
 

Fichiers joints

M

Monique

Guest
Bonjour,

Tu as quelques modifications dans ton fichier.
Et les réponses aux questions sont dans le fichier.
Suite au prochain numéro.
 

Fichiers joints

A

Archi

Guest
Génial Monique,

autre prob, plus délicat

comment dissocier des adversaires identiques
exemple:
Wittmann gagne contre deux, voir trois 45 donc valeur en I24=2 ou 3
résultats souhaité:
wittmann contre deux 45 ou contre trois 45

tu dois en avoir marre que je te sollicite autant ???

@+
 
M

Monique

Guest
Bonjour,

Plus délicat, comme tu dis.
Je n'avais pas pensé à ça.
Peut-être en reportant dans les cellules de la feuille "Données" le nombre inscrit dans la feuille "Synthèse".
En I24, ça donnerait quelque chose comme :
=SI(Synthèse!I24>0;(Synthèse!I24&SUBSTITUE(SUBSTITUE(SUBSTITUE(Synthèse!$D24;"NCF";120);"NC";100);"F";"")+LIGNE()/10000-SUBSTITUE(Synthèse!I$4;"NC";100)*0,999)*1;LIGNE()/10000)
Format de la cellule [<1]"";0"-"00
Et ça te donne 2-20 en I24 si Wittmann gagne 2 fois contre un 45.
La suite, je ne vois pas pour l'instant.
 
A

Archi

Guest
Pourquoi ne pas prendre la valeur "données!I24" diviser par la valeur "Synthèse!I24" ??

En faite , ma seule préocupation s'est le texte en N34 en rapport avec la valeur en Synthèse!I24 par exemple

en N34, si valeur Synthèse!I24=2 donc "contre deux" 45
ou si valeur Synthèse!I24=3 donc "contre trois" 45
etc....

tu vois ce que je veux dire ???
 
M

Monique

Guest
Re,

Tu as raison, on ne touche pas à la feuille "Données"
et on peut faire quelque chose comme ça à la place de "contre" :
=SI(I38="";"";INDEX($C$4:$S$32;EQUIV(I38;$C$4:$C$32;0);EQUIV(U38;$C$4:$S$4;0)))
Format de la cellule 0" fois contre"
U38 étant le classement de l'adversaire et I38 le nom du vainqueur.
Mais je ne m'en sors pas avec le "NC" qui se trouve en S4
 
M

Monique

Guest
Re,

C'est bon, mais il faut remettre NCF à 100 (il est à 120 et c'est ça qui me donnait une erreur)
J'essaie de mettre les résultats avec des "formules-phrases"
 

Discussions similaires


Haut Bas