Office 365 Chercher le maximum d'une combinaison_Excel

nordiks

XLDnaute Nouveau
Bonjour, J'essaie de trouver la meilleure combinaison (soit celle avec le plus de points).
Afin d'y arriver, j'ai 2 conditions à respcter, soit un maximum de 12 valeurs à prendre, et que le somme de ces 12 valeurs ne dépasse pas 30 comme côtes. Ainsi, les 12 sélections donnerait le maximum de points.
Je joins le fichier, et je vous remercie de votre aide.
bonne journée
 

Fichiers joints

patricktoulon

XLDnaute Accro
bonsoir
il ne s'agit ici en aucun cas de combinaison tout du moins mécaniquement vba parlant
un simple filtre <=30 sur ta colonne cotes
et une boucle sur les visibles de ta colonnes points avec WorksheetFunction.Large(Columns(colonne point ), x)
x etant itéré a niveau du count des visibles du filtre et stoppée a 12

terminé tu a tes 12
 

nordiks

XLDnaute Nouveau
Merci Patrick, je l'ai essayé et ça ne fonctionne pas.
Il ne faut pas oublier, ma requête vise à avoir le maximum de points avec 2 critères, une somme égale à 12 pour les valeurs, et une somme égale à 30 pour les cotes.
 

patricktoulon

XLDnaute Accro
re
je ne t'ai pas donné un code mais un principe qui est on ne peut plus simple a mettre en place
et si ça fonctionne pas c'est que tu n'a pas su le mettre en place ;)
 

nordiks

XLDnaute Nouveau
Merci ODVJ, la base que tu m'a remise est super bonne. J'ai modifié les points suivants :
1) Ajouter une case pour le nombre de points (qui est mon objectif à définir) ;
2) La case Nombre de points est une SOMMEPROD des colonnes Varbon et Points.
J'ai joins le fichier, et merci beaucoup de ton aide.
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Suivant ton intitulé, je n'ai pas compris la même chose.
Voir cette formule qui calcule la somme toutes les 12 valeurs des points inférieurs à 30.
VB:
=SI(MOD(LIGNE()-5;$C$3)=0;SOMME.SI(DECALER($F6;;;-$C$3);"<="&$D$3;DECALER($F6;;;-$C$3));"")
JHA
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas