Autres calendrier perpétuel sans week-end et mercredi

ram_ia

XLDnaute Nouveau
Bonjour à tous,

Je fais appel au forum pour tenter de m'aider à trouver la manière de créer un calendrier perpétuel sans que les mercredis, les samedis et dimanches apparaissent.
Je n'ai pas trouvé cette particularité dans les autres discussions et sollicite votre aide.
J'ai su trouver pour le week-end et j'avais trouvé cette proposition pour le mercredi en imbriquant une nouvelle condition :( =SI(JOURSEM(A1;2)=5;A1+3;SI(JOURSEM(A1;2)=2;A1+2;A1+1)) sur un autre forum.
Sur ma première ligne (1er jour du mois) tout va bien. C'est à partir de la deuxième ligne que les mercredis réapparaissent.

Je joins le modèle de fichier.

Merci d'avance pour votre aide.
Bien cordialement,
Raymi
 

Pièces jointes

  • modèle.xlsx
    20.7 KB · Affichages: 15

ram_ia

XLDnaute Nouveau
Bonjour Ram_ia,
En PJ avec :
VB:
Sub Worksheet_Change(ByVal Target As Range)
    If Target.Count > 1 Then Exit Sub
    If Not Intersect(Target, [A3]) Is Nothing Then
        Application.ScreenUpdating = False: Dim L%
        MoisSuivant = Application.EDate(Target, 1)
        For L = 30 To 40
            If Cells(L, "A") >= MoisSuivant Then Exit For
        Next L
        Range("A29:A40").EntireRow.Hidden = False
        Range(Cells(L, "A"), Cells(L + 8, "A")).EntireRow.Hidden = True
        Application.ScreenUpdating = True
    End If
End Sub
qui n'est rien d'autre que la première remaniée de colonnes à lignes.

NB: Si c'est bon, pensez à clore le post en indiquant la bonne PJ. Car avec autant de PJ sur un fil le futur lecteur se demandera laquelle est la bonne. :)
Merci beaucoup Sylvanu. Je clos le post en indiquant que c'est bien le dernier fichier qui est le bon.