#valeur avec fonction trouve

noox

XLDnaute Nouveau
Bonjour,
désolé si la réponse est dans le forum, mais mes recherches ont été infructueuses:

Donc j'ai une fonction simple qui me renvoie l'erreur "#valeur" quand le test logique est faux et malheureusement en bon noob je cale.

Merci pour votre aide.
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Re : #valeur avec fonction trouve

Bonjour,

Un autre essai avec :

Code:
=SI(NB.SI(A2;"*/*");B2/2;B2)
@+
 

noox

XLDnaute Nouveau
Re : #valeur avec fonction trouve

Merci Beaucoup,
sans vouloir abuser, vous avez une idée pourquoi cela ne fonctionne pas avec "trouve"?
 

Tibo

XLDnaute Barbatruc
Re : #valeur avec fonction trouve

re,

la fonction TROUVE ne teste pas si le caractère est présent, mais retourne le rang du caractère cherché s'il est trouvé ou #VALEUR! s'il n'est pas trouvé.

Or, dans un test, #VALEUR! retourne ... #VALEUR!

Voila pourquoi il faut tester si le caractère est présent plutôt que de rechercher son rang.

Bonne journée

@+
 

hoerwind

XLDnaute Barbatruc
Re : #valeur avec fonction trouve

Bonjour, salut dyonis0s et Tibo,

Ta formule fonctionne en l'écrivant comme ceci :
=SI(ESTNUM(TROUVE("/";A2));B2/2;B2)

mais tu peux également l'écrire comme suit :
=B2/(1+(ESTNUM(TROUVE("/";A2))))
 

Discussions similaires


Haut Bas