XL 2016 utiliser une lettre/ pour une plage

julien91080

XLDnaute Junior
Bonjour à tous,

j'ai beau chercher, je ne trouve pas de solution.

imaginons une formule du type :
Colonne G= Région (Nord, Aquitaine.....)
Colonne H = Chiffre d'affaires
Cellule B1 = un sélecteur
=SOMME.SI(G1:G26;B1;H1:H26)

Ca c'est facile. Il faut juste que notre fichier de base est propre (classé) et quand on sait où chercher.

N'est il pas possible de dire :
Cellule A1 = "G""

=SOMME.SI(G1:G26;B1;A1&"1":A1&"26")

En gros, est il possible de reconstituer une plage à partir du résultat d'une autre formule et/ou le texte d'une cellule?

Cordialement,

Julien
 

julien91080

XLDnaute Junior
Bonjour Merinons,

Donc quelque chose comme cela :
=SOMME.SI(G1:G26;B1;INDIRECT(A&&"1"):INDIRECT(A&&"26")?


Apriori le && ne fonctionne pas chez moi.

julien
 

Dranreb

XLDnaute Barbatruc
Bonjour.
Non c'est =SOMME.SI(G1:G26;B1;INDIRECT(A1&"1:"&A1&"26")
Mais il y a d'autres solutions avec INDEX et DECALER. Je réserve le INDIRECT aux cas où le nom de la feuille peut varier ou si vraiment il n'est pas possible d'utiliser un numéro de colonne plutôt que son entête.
 

Discussions similaires


Haut Bas