XL 2016 Trouver une valeur à partir de deux critères

EXCELOS

XLDnaute Nouveau
Bonsoir à tous, je voudrais trouver une valeur à partir de deux critères avec la formule INDEX/EQUIV, je joins le fichier d'exemple pour une meilleure compréhension.
 

Fichiers joints

mdo100

XLDnaute Occasionnel
Bonsoir à tous, je voudrais trouver une valeur à partir de deux critères avec la formule INDEX/EQUIV, je joins le fichier d'exemple pour une meilleure compréhension.
Bonjour EXCELOS,

A tester:
En "F3 & G3" listes déroulantes.
En "H3"
VB:
=SIERREUR(INDEX($D$3:$D$9;EQUIV($F$3&$G$3;$B$3:$B$9&$C$3:$C$9;0));"Non OK")
Formule matricielle à valider avec ctrl + maj + entrée

Cordialement.
 

Fichiers joints

ChRouca

XLDnaute Nouveau
Bonsoir à tous, je voudrais trouver une valeur à partir de deux critères avec la formule INDEX/EQUIV, je joins le fichier d'exemple pour une meilleure compréhension.
Bonjour,
En supposant que vous souhaitiez faire votre recherche en fonction de la POSITION définie en A11, le résultat de votre recherche en E11 serait fourni par la formule : =INDEX($D$2:$D$9,EQUIV($A11,$B$2:$B$9))
En supposant que vous souhaitiez faire votre recherche en fonction du Prix unitaire définie en A12, le résultat de votre recherche en E12 serait fourni par la formule : =INDEX($D$2:$D$9,EQUIV($A12,$C$2:C$9))
 

SebSemdee

XLDnaute Nouveau
Bonjour
Définir la plage d'index (B:B&"@"&C:C")
Valeur cherchée en ligne 3 (B3&"@"&C3)

Le &"@"& fait fonction d'assemblage pour autant de critères souhaités, ici 2.

Veiller à bien respecter l'ordre des critères qui sera identique dans la plage indexée et dans la valeur cherchée.

Souhaitant avoir compris votre besoin

Sébastien
 

EXCELOS

XLDnaute Nouveau
Bonjour EXCELOS,

A tester:
En "F3 & G3" listes déroulantes.
En "H3"
VB:
=SIERREUR(INDEX($D$3:$D$9;EQUIV($F$3&$G$3;$B$3:$B$9&$C$3:$C$9;0));"Non OK")
Formule matricielle à valider avec ctrl + maj + entrée

Cordialement.
Bonjour Modo100, Merci pour la solution proposé qui me va à merveille.
 

EXCELOS

XLDnaute Nouveau
Bonjour,
En supposant que vous souhaitiez faire votre recherche en fonction de la POSITION définie en A11, le résultat de votre recherche en E11 serait fourni par la formule : =INDEX($D$2:$D$9,EQUIV($A11,$B$2:$B$9))
En supposant que vous souhaitiez faire votre recherche en fonction du Prix unitaire définie en A12, le résultat de votre recherche en E12 serait fourni par la formule : =INDEX($D$2:$D$9,EQUIV($A12,$C$2:C$9))
Bonjour ChRouca, merci d'avoir pris du temps pour réfléchir à mon problème et si tu exploitais mon fichier pour clairement m'illustrer tes hypothèses, merci !
 

EXCELOS

XLDnaute Nouveau
Bonjour
Définir la plage d'index (B:B&"@"&C:C")
Valeur cherchée en ligne 3 (B3&"@"&C3)

Le &"@"& fait fonction d'assemblage pour autant de critères souhaités, ici 2.

Veiller à bien respecter l'ordre des critères qui sera identique dans la plage indexée et dans la valeur cherchée.

Souhaitant avoir compris votre besoin

Sébastien
Bonjour SebSemdee, merci d'avoir pris du temps pour réfléchir à mon problème et si tu exploitais mon fichier pour clairement m'illustrer tes hypothèses, merci !
 

SebSemdee

XLDnaute Nouveau
Bonjour SebSemdee, merci d'avoir pris du temps pour réfléchir à mon problème et si tu exploitais mon fichier pour clairement m'illustrer tes hypothèses, merci !
Les explications dans le fichier : la formule correspondant à ton besoin devrait être SIERREUR(INDEX(B3:D9;EQUIV(H3&"@"&I3;B3:B9&"@"&C3:C9;0);3);"non référencé")

Sébastien
 

Fichiers joints

Discussions similaires


Haut Bas