Microsoft 365 Trouver les 10 plus grandes valeurs avec conditions

Jo Mortu

XLDnaute Nouveau
Bonjour à tous,

Je vous sollicite, car je souhaiterai à partir d'une base, trouver les 10 plus grandes valeurs par société, Catégorie socio professionnelle et sexe..

J'ai essayé avec grande valeur donc pas de souci, mais je ne trouve pas la façon de faire quand je dois intégrer des critères.

Ci-joint ma base pour exemple.

Merci par avance.

Bonne journée

Jo
 

Pièces jointes

  • Grandes valeurs.xlsx
    12.2 KB · Affichages: 6

Jocelyn

XLDnaute Barbatruc
re,

lignes($1:1) renvoie 1 puisqu'elle compte le nombre de lignes dans ($1:1) en tirant vers le bas on obtient lignes($1:2) soit résultat 2 cela permet en étirant de dire grande.valeur 1, 2, 3 etc aussi loin que l'on étire

J'espère que c'est compréhensible autrement n(hésites pas

Cordialement
 

Jo Mortu

XLDnaute Nouveau
re,

lignes($1:1) renvoie 1 puisqu'elle compte le nombre de lignes dans ($1:1) en tirant vers le bas on obtient lignes($1:2) soit résultat 2 cela permet en étirant de dire grande.valeur 1, 2, 3 etc aussi loin que l'on étire

J'espère que c'est compréhensible autrement n(hésites pas

Cordialement
Ok c'est parfait, merci beaucoup pour votre explication et votre disponibilité.

Bonne journée
 

R@chid

XLDnaute Barbatruc
Bonjour @ tous,
T'es sous Excel pour Microsoft 365, tu peux profiter des fonctions FILTRE() et SEQUENCE().
En G2 :
VB:
=SIERREUR(GRANDE.VALEUR(FILTRE(D2:D43;(A2:A43=K2)*(B2:B43=K3)*(C2:C43=K4));SEQUENCE(10));"")
La formule ne nécessite ni validation matricielle ni incrémentation vers le bas.


Cordialement
 

Discussions similaires

Haut Bas