XL 2016 stock moyen pondéré

Sylvain21

XLDnaute Nouveau
Bonjour à tous,

Je souhaite automatisé le calcul du stock moyen pondéré avec excel.
Le calcul est le suivant : stock moyen pondéré pour une période = ((stock après une entrée + stock avant une seconde entrée)/2)*(le nombre de jours sur la période)).
La somme des stocks moyens des périodes sera divisée par le nombre de jours de toutes les périodes.
Pour cela j'ai une feuille de calcul avec pour une référence des dates, des entrées et des sorties de produits. J'ai un stock initial qui me permet de définir le stock après chaque mouvement.

La difficulté pour moi est de délimité les périodes par excel et donc d'automatisé ce calcul.

Pour une meilleur compréhension je vous joins un exemple avec les résultats que je souhaiterai obtenir avec votre aide.

Vous remerciant d'avance pour vos propositions,

Sylvain
 

Fichiers joints

laurent3372

XLDnaute Occasionnel
Supporter XLD
Bonsoir,

J'ai trouvé une formule pour calculer la durée de la période, en supposant qu'au début de chaque nouvelle période la cellule "Sorties" (en E4) est vide. Attention, c'est une formule matricielle (à valider par Ctrl+Maj+Entrée)
VB:
=SI($E4="";INDIRECT("$B"&MIN(SI($E5:$E999="";LIGNE($E5:$E999)))-1)-$B4;"")
J'ai arrangé toutes tes formules pour que tu puisses les recopier vers le bas depuis la première ligne.

Cordialement,
--
LR
 

Fichiers joints

Sylvain21

XLDnaute Nouveau
Un grand Merci pour votre réponse rapide!

Aussi les formules peuvent-elles fonctionner avec les dates les plus récentes au dessus du tableau?

Bien cordialement,
Sylvain
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas