Office 365 SOMMEPROD

hbb

XLDnaute Occasionnel
Bonjour à tous,
Je suis à la recherche d'une formule matricielle à plusieurs conditions.
Je me suis totalement emmêlé les pinceaux avec toutes les conditions requises...

Je sollicite votre aide, toujours aussi pertinente, avec un tableau simplifié que j'ai mis en pièce jointe.
Le résultat dans les cellules rouges est bon mais la formule n'est pas du tout adaptée à plusieurs dizaines de lignes de mon document original !

merci d'avance pour votre aide,
A bientôt,
Hbb
 

Fichiers joints

sylvanu

XLDnaute Impliqué
Supporter XLD
Bonjour HBB, en matriciel on peut faire ça :
{=SOMMEPROD($C$12:$C$15;TRANSPOSE(D4:G4))} pour les pommes
En tirant vers le bas, on a la valeur pour tous les fruits.
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour hbb, sylvanu,

un essai en fichier joint avec une formule légèrement différente mais toujours matricielle

Cordialement
 

Fichiers joints

hbb

XLDnaute Occasionnel
Ok merci Sylvanu et Jocelyn pour vos solutions !
Effectivement, tous les produits doivent être dans le même ordre pour éviter toute erreur....
Je vais me pencher dessus,
Bonne soirée et merci encore !!!
hbb
 

R@chid

XLDnaute Barbatruc
Bonjour @ tous,
J'ai pas trouvé mieux que de passer par un tableau intermédiaire.
Voir PJ


Cordialement
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas