RESOLU - Coloriser une cellule par rapport à la somme d'une autre cellule

Scheerami

XLDnaute Occasionnel
Bonjour le forum et merci pour votre aide.

Je souhaiterai qu'une cellule se colorise lorsque la somme est égale à une autre cellule afin de montrer immédiatement quel est le meilleur d'entre eux.

Pour une meilleur compréhension je vous joins un fichier.

En vous remerciant d'avance pour le temps que vous me donnez Scheera
 
Dernière édition:

Dugenou

XLDnaute Barbatruc
Supporter XLD
Re : Coloriser une cellule par rapport à la somme d'une autre cellule

Bonjour,
I2a : j'ai l'impression que ce que tu as fait ne fonctionne pas
scheerami : avec ces formules : pas besoin de validation matricielle !
voir pj avec un extra : le nom du gagnant dans la colonne suivante
 

Fichiers joints

Scheerami

XLDnaute Occasionnel
Re : Coloriser une cellule par rapport à la somme d'une autre cellule

Bonsoir le forum et merci à vous Dugenou et i2a pour le temps consacré.
Vos deux réponses fonctionnent mais:

Dugenou, la formule fonctionne mais il y a un petit problème, si dans la case B le chiffre est 1, la case correspondant en L (le gagnant) affiche un 0 et, je n'arrive pas à comprendre pourquoi!
Pouvez-vous m'expliquer SVP Merci
 

Dugenou

XLDnaute Barbatruc
Supporter XLD
Re : Coloriser une cellule par rapport à la somme d'une autre cellule

Bonjour,
En effet, c'est du au fait que dans ce cas le total est égal au prix unitaire. Comme le equiv renvoie l'adresse de la première occurrence il renvoie un N° qui ne convient pas pour afficher le contenu de la ligne1 dont une cellule sur 2 est vide.
Il vaut mieux donc utiliser la formule ci après (plus propre à mon avis) qui recherche le prix unitaire du gagnant avec EQUIV(K3/B3;$C3:$J3;0) et donc sans le -1 (qui était laid :))


=SI(K3>0;INDEX($C$1:$J$1;;EQUIV(K3/B3;$C3:$J3;0));"")
 

Scheerami

XLDnaute Occasionnel
Re : Coloriser une cellule par rapport à la somme d'une autre cellule

Bonsoir Dugenou et encore MERCI pour votre aide

Cette formule fonctionne bien sauf que : si il y a le chiffre 0.11 dans une cellule d'une colonne prix unitaire, dans la cellule L correspondante, le symbole "#NA" s'affiche.
J'ai tenté plusieurs solutions mais en vains, je ne comprends pas le pourquoi.
Merci de m'expliquer ce pourquoi. Scheera

Re bonjour le furum et à vous Dugenou.

En essayant plusieurs tentatives, en vain, je me suis rendu compte qu'un nombre commençant par "0,xxx" donne toujours le même symbole.

Merci pour votre aide Scheera
 
Dernière édition:

Dugenou

XLDnaute Barbatruc
Supporter XLD
Re : Coloriser une cellule par rapport à la somme d'une autre cellule

Bonjour,
Cela n'arrive pas sur toutes les lignes mais seulement quand le nb d'unités est important.
C'est, je pense, lié à la gestion des nombreux chiffres aprés la virgule

en travaillant sur un arrondi à 6 chiffres derrière la virgule le pb disparaît.
=SI(K3>0;INDEX($C$1:$J$1;;EQUIV(ARRONDI(K3/B3;6);$C3:$J3;0));"")
voir pj
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas