XL 2016 recherchev avec SI

harveyspecter

XLDnaute Occasionnel
bonjour,

je recherche attribué un numero a des individus en utilisant rechercheV et si mais j'ai des N#A sans aucune raisons.


Dois je utiliser une autre formule ?

Mercii
 

Fichiers joints

xUpsilon

XLDnaute Impliqué
Bonjour,

Avec RechercheV, le problème reste si tu ne trouves pas le terme que tu cherches dans la première colonne de ton tableau.
Le solution consiste à passer par Index/Equiv.

Bonne continuation
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour,
Ou sécuriser la seconde partie de la formule avec un second Sierreur si le nom n'existe pas pour supprimer le #N/A :
VB:
=SIERREUR(RECHERCHEV(E6;table1!$E$7:$F$12;2;FAUX);SIERREUR(SI(RECHERCHEV(E6;table2!$E$6:$G$13;2;FAUX);"SORTIE";"");"INEXISTANT"))
 
Dernière édition:

harveyspecter

XLDnaute Occasionnel
Merci à tous pour vos retour.

Du coup puis je lui dire que si le nom n'est ni dans la table 1 et 2 alors inverser le nom et prenom et recherchev dans la table 1 ??

lexemple cf de benzema karim
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas