Rechercher une valeur dans un tableau

Pierrick1910

XLDnaute Nouveau
[RESOLU] Rechercher une valeur dans un tableau

Bonjour à tous,

Je galère sur Excel pour trouver un truc qui est réalisable, j'en suis sûr !

J'ai un tableau.
Je veux rechercher dans ce tableau la valeur correspondant à une colonne et à une ligne. Je peux le faire avec la fonction index.
Mais mes colonne et mes lignes ont des titres, et je voudrai pouvoir rechercher dans ce tableau à partir de ces titres.
En gros j'ai une feuille avec mon tableau et dans une autre feuille, j'ai dans une première case le titre de la ligne, dans la deuxième case le titre de la colonne, et je veux afficher dans une troisième case la valeur du tableau qui correspond.
J'espère avoir été assez clair.
Sinon vous me demandez.
Merci de votre aide.
++
Pierrick
 
Dernière édition:

bibas

XLDnaute Nouveau
Re : Rechercher une valeur dans un tableau

Bonjour ,

Voila j'ai un tableau est je voudrais avec des formules, trouver une valeur la plus proche dans le tableau et que cela me renvoi a l'intitulé de la ligne et de la commande.

Merci de m'aider
 

Pierrick1910

XLDnaute Nouveau
Re : Rechercher une valeur dans un tableau

Je ne comprends pas bien.
Tu as ce tableau de données. OK.
A partir de quoi doit-il effectuer ça recherche ?

Tu lui donnes 8.04, et tu veux qu'il te donne 16mm et/ou 32mm ? C'est ça ?

Tiens moi au courant.
 

Tibo

XLDnaute Barbatruc
Re : Rechercher une valeur dans un tableau

Bonjour,

Petit détail pour commencer, ça aurait été sympa de nous joindre un fichier Excel plutôt qu'une image (tout comme on envoie pas une photo du moteur de sa voiture à son garagiste).

Sinon, une solution avec formule matricielle :

en B15 : le chiffre recherché

en B18 :

Code:
=SI(LIGNE()-17>SOMMEPROD((($B$3:$K$13=$B$15)*(LIGNE($B$3:$B$13)+
COLONNE($B$3:$K$3)/100)<>0)*1);"";INDEX($A$3:$A$13;ENT(PETITE.VALEUR(
SI(($B$3:$K$13=$B$15)*(LIGNE($B$3:$B$13)+COLONNE($B$3:$K$3)/100)<>0;
($B$3:$K$13=$B$15)*(LIGNE($B$3:$B$13)+COLONNE($B$3:$K$3)/100));
LIGNE()-17))-2))

en C18 :

Code:
=SI(LIGNE()-17>SOMMEPROD((($B$3:$K$13=$B$15)*(LIGNE($B$3:$B$13)+
COLONNE($B$3:$K$3)/100)<>0)*1);"";INDEX($B$2:$K$2;MOD(PETITE.VALEUR(
SI(($B$3:$K$13=$B$15)*(LIGNE($B$3:$B$13)+COLONNE($B$3:$K$3)/100)<>0;
($B$3:$K$13=$B$15)*(LIGNE($B$3:$B$13)+COLONNE($B$3:$K$3)/100));
LIGNE()-17);1)*100-1))

Ces deux formules matricielles sont à valider par CTRL + MAJ + ENTREE

Formules à recopier vers le bas.

Pour plus de facilités, je joins un fichier.

Je te laisse tester.

@+
 

Pièces jointes

  • bibas.zip
    2.5 KB · Affichages: 433
  • bibas.zip
    2.5 KB · Affichages: 436
  • bibas.zip
    2.5 KB · Affichages: 440

Pierrick1910

XLDnaute Nouveau
Re : Rechercher une valeur dans un tableau

Effectivement, ça me parait être la solution.

De mon coté j'avais fait un truc bcp plus simple mais qui ne marche pas lorsqu'il y a 2 valeurs identiques dans le tableau.

Je te le mets en pj qd même mon résultat.
J'ai détaillé les formules en plusieurs étapes.
 

Pièces jointes

  • exple xkl.xls
    16.5 KB · Affichages: 635

Tibo

XLDnaute Barbatruc
Re : Rechercher une valeur dans un tableau

Bonjour,

Une autre solution dans l'hypothèse où il n'y a qu'une seule valeur :

Diamètre :

Code:
=INDEX($A$1:$A$13;SOMMEPROD(($B$3:$K$13=[COLOR=red]B20[/COLOR])*LIGNE($B$3:$B$13)))

Section :

Code:
=INDEX($A$2:$K$2;SOMMEPROD(($B$3:$K$13=[COLOR=red]B20[/COLOR])*COLONNE($B$2:$K$2)))

La valeur à chercher étant en B20 (sur la base du fichier de Pierrick1910)

Pas besoin de validation matricielle

@+
 

bibas

XLDnaute Nouveau
Re : Rechercher une valeur dans un tableau

Un grand merci a toi

je te transmet la version excel, si je n'ai pas pus le faire avant c'est parce que j'étais sous open office

A priori les formules que vous m'avez donnez ne marche que avec des valeurs exact ce qui n'est pas le cas ici


Merci d'avance
 

Pièces jointes

  • bibas2.xls
    27 KB · Affichages: 457
Dernière édition:

Tibo

XLDnaute Barbatruc
Re : Rechercher une valeur dans un tableau

Bonjour,

Comme quoi un fichier Excel nous aurait tous arrangé. Tu aurais obtenu une réponse plus rapidement et on aurait évité des recherches inutiles.

Voir le fichier que j'avais envoyé adapté.

A adapter à ton vrai fichier.

@+
 

Pièces jointes

  • bibas2.zip
    2.6 KB · Affichages: 521

Discussions similaires

Haut Bas