Résolu Autres Nombre de jours par mois pour une periode et changement W.End

chaelie2015

XLDnaute Accro
Bonsoir Forum
je souhaite afficher nombre de jour par mois pour une periode via formule.
exemple : periode du 22/03/2020 au 04/04/2020 donc j'ai pour le mois de MARS j'ai 08 jours et le mois d'AVRIL j'ai 02 jours
NB: le week-end c'est Vendredi et samedi
Salutations
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

Dernière édition:

chaelie2015

XLDnaute Accro
Re
j'ai trouvé cette solution
pour le mois de Mars : =NB.JOURS.OUVRES(A2;MIN(C2;FIN.MOIS(A2;0)))
Pour le mois d'Avril : =SI(MOIS(C2)<>MOIS(A2);NB.JOURS.OUVRES(FIN.MOIS(C2;-1)+1;C2);0)
Merci FORUM
- 2eme souci comment faire pour modifier les week end de SAMEDI - DIMANCHE au vendredi-samedi
merci par avance
 

job75

XLDnaute Barbatruc
Bonjour chaelie2015,

En E2 =SOMMEPROD(N(JOURSEM(LIGNE(INDIRECT(A2&":"&FIN.MOIS(A2;0))))<6))

En F2 =SOMMEPROD(N(JOURSEM(LIGNE(INDIRECT(FIN.MOIS(C2;-1)+1&":"&C2)))<6))

Ici on ne se préoccupe pas des jours fériés.

A+
 

Fichiers joints

chaelie2015

XLDnaute Accro
Bonjour chaelie2015,

En E2 =SOMMEPROD(N(JOURSEM(LIGNE(INDIRECT(A2&":"&FIN.MOIS(A2;0))))<6))

En F2 =SOMMEPROD(N(JOURSEM(LIGNE(INDIRECT(FIN.MOIS(C2;-1)+1&":"&C2)))<6))

Ici on ne se préoccupe pas des jours fériés.

A+
Bonjour Job75,
merci pour la réponse , mais ça fonctionne pas bien si je change les dates exemple
05/04/2020 au 19/04/2020 ?
 

Fichiers joints

chaelie2015

XLDnaute Accro
bonjour,



Suivant votre version excel, avec la fonction NB.JOURS.OUVRES.INTL dont le troisième argument permet de choisir les jours de Week-End.

Cordialement
Bonjour Roblochon
Merci pour la réponse et la remarque, pour ce souci du Week-End et avec la formule du Post 3 (Job75) est resolu, encore une fois merci.
mon souci maintenant est dans l'application de la réponse de JOB comme indiqué dans mon post 4
a+
 

job75

XLDnaute Barbatruc
Le problème posé au post #1 concernait 2 mois.

S'il peut n'y en avoir qu'un il faut bien sûr compléter les formules, fichier (2) :
Code:
=SOMMEPROD(N(JOURSEM(LIGNE(INDIRECT(A2&":"&MIN(C2;FIN.MOIS(A2;0)))))<6))

=SI(MOIS(A2)=MOIS(C2);"";SOMMEPROD(N(JOURSEM(LIGNE(INDIRECT(FIN.MOIS(C2;-1)+1&":"&C2)))<6)))
Salut Roblocho, oui avec NB.JOURS.OUVRES.INTL c'est plus simple.
 
Ce message a été identifié comme étant une solution!

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas