Modifier menu déroulant

JP54

XLDnaute Junior
Bonjour,
J'ai créé une liste de date (1996 à 2013). Avec cette liste j'ai créé un menu déroulant dans une autre feuille avec validation des donnés. Mon menu déroulant fonctionne.
Tous les ans je vais devoir ajouter les années 2014 etc...
Ma question est simple, comment faire pour modifier mon menu déroulant en ajoutant les années
 

Fichiers joints

excfl

XLDnaute Accro
Re : Modifier menu déroulant

Bonsoir JP54,

Changer l'adresse du nom calendrier :

=Calendrier!$A$2:$A$32

Et dans la feuille calendrier : compléter les années jusqu'à la ligne 32 par ex.

excfl
 

JP54

XLDnaute Junior
Re : Modifier menu déroulant

En faite c'est très simple, je n'y avais pas pensé
Merci beaucoup excfl
 

JCGL

XLDnaute Barbatruc
Re : Modifier menu déroulant

Bonjour à tous,

Peux-tu essayer en feuille Calendrier :

En A2 : 1996
En A3 et suivantes : =SI(A2="";"";SI(ANNEE(AUJOURDHUI())+1<A2+1;"";A2+1))

Pour la liste :

Capture 1.png

A+ à tous
 

Fichiers joints

david84

XLDnaute Barbatruc
Re : Modifier menu déroulant

Bonsoir,
remplir la colonne A avec les années (jusqu'à 2020 ou plus par exemple).
Pour n'avoir dans le menu déroulant que les années antérieures ou égales à l'année en cours, entrer dans le gestionnaire des noms :
Code:
=DECALER(Calendrier!$A$2;;;EQUIV(ANNEE(AUJOURDHUI());Calendrier!$A:$A;0)-1)
Cela te permet d'avoir uniquement les années "utiles" dans ton menu déroulant.
A+
 

JP54

XLDnaute Junior
Re : Modifier menu déroulant

Bonjour à tous,

Peux-tu essayer en feuille Calendrier :

En A2 : 1996
En A3 et suivantes : =SI(A2="";"";SI(ANNEE(AUJOURDHUI())+1<A2+1;"";A2+1))

Pour la liste :

Voir la pièce jointe 288043

A+ à tous
je vais essayer JCGL, mais quel changement par rapport à la réponse de excfl

Bonjour, JP54, excfl :), JCGL (+ bise) :), le Forum,

Une autre possibilité en pièce jointe (plage dynamique... Cf. le gestionnaire de noms).

A bientôt :)
Merci DoubleZero

Bonsoir,
remplir la colonne A avec les années (jusqu'à 2020 ou plus par exemple).
Pour n'avoir dans le menu déroulant que les années antérieures ou égales à l'année en cours, entrer dans le gestionnaire des noms :
Code:
=DECALER(Calendrier!$A$2;;;EQUIV(ANNEE(AUJOURDHUI());Calendrier!$A:$A;0)-1)
Cela te permet d'avoir uniquement les années "utiles" dans ton menu déroulant.
A+
Merci David84, ça peut m'être utile mais dans un autre fichier
 

JCGL

XLDnaute Barbatruc
Re : Modifier menu déroulant

Bonjour à tous,
Salut 00,

La liste est dynamique...
Maintenant tu as 2014 et en 2014 tu auras 2015.

Bises à 00
A+ à tous
 

Discussions similaires


Haut Bas