XL 2019 La fonction sommeprod

Sanni

XLDnaute Nouveau
Bonsoir à tous! J'ai besoin de votre aide!
J'essaie d'utiliser la fonction sommeprod pour renvoyer du texte mais cela ne marche pas car le résultat renvoyé n'est pas juste.
J'ai utilisé la fonction sommeprod avec deux conditions qui sont la cellule B4 et A5 de la feuil1. La feuil2 est l'endroit où sera faite la recherche.
Voir le fichier en pièces jointe.merci
 

Pièces jointes

  • Sommeprod.xlsx
    14.7 KB · Affichages: 8

djidji59430

XLDnaute Barbatruc
Bonjour à tous,

Comme son nom l'indique, sommeprod() fait des produits et des sommes.
Donc, travaille sur des nombres. On ne fait pas de produit avec des mots !
si tu écris
=SOMMEPROD(($B$4:$P$4=B4)*($A$5:$A$17=A5)*($B$5:$P$18)),
la plage $B$5:$P$18 ne doit contenir que des nombres, mais pas de texte.
S'il y des textes, tu dois utiliser la fonction index pour une plage

Crdlmt
 

Sanni

XLDnaute Nouveau
Bonjour à tous,

Comme son nom l'indique, sommeprod() fait des produits et des sommes.
Donc, travaille sur des nombres. On ne fait pas de produit avec des mots !
si tu écris
=SOMMEPROD(($B$4:$P$4=B4)*($A$5:$A$17=A5)*($B$5:$P$18)),
la plage $B$5:$P$18 ne doit contenir que des nombres, mais pas de texte.
S'il y des textes, tu dois utiliser la fonction index pour une plage

Crdlmt
oui j'ai utilisé la fonction index mais le résultat n'est pas juste...merci de voir la pièce jointe
 

chris

XLDnaute Barbatruc
RE

Le souci est que tu as plusieurs réponses (2 et parfois plus) pour une même date et un même code

Ici on perd 11 réponses

J'ai ajouté deux variantes PowerQuery listant les n noms à l'intersection Date/Code des daes et codes choisis (dans l'onglet Choix
  • l'une ne listant que les dates et codes ayant des noms
  • l'autre listant toutes les dates et codes
 

Pièces jointes

  • INDEX_EQUIV_PQ.xlsx
    40.3 KB · Affichages: 2
Dernière édition:

Sanni

XLDnaute Nouveau
Merci beaucoup à vous..
RE

Le souci est que tu as plusieurs réponses (2 et parfois plus) pour une même date et un même code

Ici on perd 11 réponses

J'ai ajouté deux variantes PowerQuery listant les n noms à l'intersection Date/Code des daes et codes choisis (dans l'onglet Choix
  • l'une ne listant que les dates et codes ayant des noms
  • l'autre listant toutes les dates et codes
 

Discussions similaires

Statistiques des forums

Discussions
284 862
Messages
1 863 696
Membres
155 617
dernier inscrit
MoriSI
Haut Bas