incrémenter celulles grace à une liste deroulante.

Bulit17

XLDnaute Nouveau
Bonjour a tous,

je ne suis pas un grand expert en excel, et je plante sur un sujet. je viens sur ce forum ou j'ai trouver souvent des solution a mes problèmes sans pour autant m'inscrire. Mais aujourd'hui je saute le pas :)

Voila mon problème, J'ai un tableau d'inventaire d'outils et je doit créer des kits d'outils. Pour cela sur une feuille ou j'ai un inventaire général, et une autre ou j'ai ma matrice de kit d'outils.

Dans l'inventaire générale j'ai plusieurs colonne A:type d'outils ; B:fonction, C:code ref, D:Armoire

Dans ma Matrice d'outils j'ai un autre tableau ou j'ai dans la colonne A: type d'outil avec liste déroulante pour choisir mes outils, B:Fonction, C: Armoire.

Et mon souhait serai que lorsque je sélectionne un outils dans ma liste déroulante les deux autre colonne se copie automatiquement.
 

Bulit17

XLDnaute Nouveau
merci de ta reponse, mais quand j'ai cree ce tablea je me suis trompé . il n'y a pas que 4 type mais autant de type que de ligne au tableau
 

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
c'est pas grave : les deux colonnes sont bien calculées à partir de la colonne A
Il vous suffit de modifier la liste déroulante (données / validation)
Cordialement
 

Bulit17

XLDnaute Nouveau
ok, merci pour la solution a mon problème.
J'ai une autre question , si un jour je crée une nouvelle page, comment je doit modifier la formule pour qu'elle recherche dans deux tableau diffèrent ?
 

Bulit17

XLDnaute Nouveau
j'ai un autre soucis avec une formule
=NB.SI('Modele vierge'!$F$19:$K$34;[PN])
cette formule me fait la recherche que sur une seul page, je voudrais savoir comment faire pour dire que cette recherche s'effectue sur tout les feuille du classeur et nom sur une seule ?

le modèle vierge se transforme et devient une autre page avec un autre nom.
 

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
Sauf à faire un TCD sur plusieurs feuilles ou une formule matricielle il faut faire un NB.SI par feuille : le tout dans la même formule :

=NB.SI('Modele vierge'!$F$19:$K$34;[PN])+NB.SI('feuil1'!$F$19:$K$34;[PN])+NB.SI('feuil2'!$F$19:$K$34;[PN]) etc ...

Cordialement
 

Bulit17

XLDnaute Nouveau
Ou alors il faut que je prenne le problème dans l'autre sens que le valeur que je cherche se compte sur ma feuille et se rajoute au tableau ou j''avais ma formule avant ?
 

Bulit17

XLDnaute Nouveau
c'est dans la colonne "sortie" des tableau fournisseur que je voudrais que le décompte se fasse suivant le choix de la liste a étage que j'ai faite pour sélectionner les fournisseur
 

Bulit17

XLDnaute Nouveau
dans colonne sortie des tableau fournisseur il faudrait compter le nombre d'occurrence qui sont dans les pages client, c'est pas facile a expliqué. :)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas