XL 2019 Formule pour masquer les 0 combinée à une autre formule

Mel62

XLDnaute Nouveau
Bonsoir à tous,

J'ai encore besoin d'un peu d'aide avec Excel. En effet, j'aurais besoin de faire dire à Excel de ne pas afficher les 0 mais plutôt une cellule vide.
La difficulté est que j'ai déjà une formule dans la cellule ; il faudrait peut-être combiner les formules.
Donc en pratique=SI(A2=0;"") ne marche pas car j'ai déjà une formule dedans (en l'occurence =SIERREUR(A2;"")

Comment combiner les formules et répondre à mon besoin ?

Merci par avance de votre aide.

Mel
 

Modeste geedee

XLDnaute Barbatruc
Bonsour®
Bonsoir à tous,
J'ai encore besoin d'un peu d'aide avec Excel. En effet, j'aurais besoin de faire dire à Excel de ne pas afficher les 0 mais plutôt une cellule vide.
La difficulté est que j'ai déjà une formule dans la cellule ; il faudrait peut-être combiner les formules.
Donc en pratique=SI(A2=0;"") ne marche pas car j'ai déjà une formule dedans (en l'occurence =SIERREUR(A2;"")
Comment combiner les formules et répondre à mon besoin ?
Merci par avance de votre aide.
Mel
appliquer un format qui n'affiche pas les 0
un format de cellule accepte 4 arguments
le premier argument concerne le format appliqué aux nombres positifs
le second le format appliqué aux nombres négatifs
le 3éme le format appliqué à la valeur 0
le 4éme le format appliqué au texte
ex :
Standard;-0,000; ;@texte
1575572595875.png
 
Dernière édition:

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour à tous
Utilisez un format personnalisé qui n'affiche pas les 0 : dans accueil, cliquer sur la flèche à droite de standard, choisir autres format numériques / personnalisé et entrer 0;0; dans le type.
Cordialement
 

Mel62

XLDnaute Nouveau
Ca marche à merveille
=SIERREUR(1/(1/B2);"")

merci à tous c'est vraiment gentil de traiter ma demande !!!
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas