Fonction SI

JP54

XLDnaute Junior
Bonjour,
J'ai un fichier de validation séquence qui fonctionne en fonction de la date pour savoir si le module a été acquis au 1er, 2ème ou 3ème trimestre
Les cellules P10, S10 et V10 sont affectées au bulletin du 1er, 2ème et 3ème trimestre
Dans ces 3 cellules j'ai une fonction SI qui reprend les 3 évaluations. Elles fonctionnent mais à cause de l'ordre chronologique de la fonction SI (je pense que ça vient de ça) ça ma pose des problèmes.
je m'explique
Si dans C10 je sélectionne VA (en voix d'acquisition), ça s'affiche bien dans P9 et P10
Si dans F10 je sélectionne A (acquis), ça s'affiche bien dans Q9 et P10
Mais si toujours dans F10 je sélectionne NA (non acquis) ça s'affiche bien dans Q9 mais pas dans P10

Moi je voudrais que dans P10 s'affiche soit P9 soit Q9 soit R9.
je pense que ça vient de l'ordre chronologique de ma fonction, j'ai bien sur inversé les critères mais ça me pose quand même des problèmes.
Cette fonction peut-elle être modifiée ou peut-elle remplacer par une autre fonction.
Merci pour votre aide
 

Fichiers joints

job75

XLDnaute Barbatruc
Re : Fonction SI

Bonjour JP54,

Voyez le fichier joint et cette formule en P10 :

Code:
=SIERREUR(RECHERCHEV(RECHERCHE("zzz";$P9:R9);$C12:$D15;2;0);"")
à copier sur S10 et V10.

Notez que SIERREUR ne fonctionne pas sur les versions antérieures à Excel 2007.

Cette formule fonctionnera sur toute version :

Code:
=SI(ESTNA(EQUIV("zzz";$P9:R9));"";RECHERCHEV(RECHERCHE("zzz";$P9:R9);$C12:$D15;2;0))
ou aussi celle-ci, un peu plus simple :

Code:
=SI(NB.SI($P9:R9;"*");RECHERCHEV(RECHERCHE("zzz";$P9:R9);$C12:$D15;2;0);"")
Edit 1 : j'ajoute le signe $ devant P9 puisque apparemment vous voulez cumuler les plages en S10 et V10.

Edit 2 : j'utilise RECHERCHE, plus simple que INDEX/EQUIV.

A+
 

Fichiers joints

Dernière édition:

Paf

XLDnaute Barbatruc
Re : Fonction SI

Bonjour

avant de modifier la formule, il faudrait savoir l'ordre de priorité des 4 valeurs possibles en P9,Q9,R9.

si P9 = A Q9 = NA R9=VA que doit on trouver en P10 ?

A+

Edit : Bonjour job75
 

JP54

XLDnaute Junior
Re : Fonction SI

Bonsoir,
Paf, je ne veux pas de priorité, c'est justement ce qui me posait problème. Comme le dis Job je veux la dernière valeur.

C'est tout à fait ce que je voulais, j'ai essayer plusieurs choses mais sans vraiment trouvé la solution et toi tu me la trouves avec 3 formules différentes. Jolie travail ;)

Voyant que ça ne fonctionnait pas avec SI, j'ai essayé avec RECHECHEV mais sans succès. Je vais comparé ta formule avec la mienne pour voir mes erreurs.

Merci beaucoup pour votre aide, je vais pouvoir avancé
 

djidji59430

XLDnaute Accro
Re : Fonction SI

Bonjour,


je l'avais fait tout a l'heure, d'une autre façon, avec un petit tableau, puis j'ai arreté quand j' ai vu que le resultat du 1er trimestre disparait quand on passe au second. C'est voulu ?
Sinon, il faut passer en VBA - je suis nul-
 

Fichiers joints

JP54

XLDnaute Junior
Re : Fonction SI

Bonjour,


je l'avais fait tout a l'heure, d'une autre façon, avec un petit tableau, puis j'ai arreté quand j' ai vu que le resultat du 1er trimestre disparait quand on passe au second. C'est voulu ?
Sinon, il faut passer en VBA - je suis nul-
Oui c'est voulu, ta formule fonctionne parfaitement, c'est normal qu'il n'y ai rien dans le premier trimestre puis que les dates choisis sont en janvier donc deuxième trimestre.
Merci beaucoup pour cette formule différente de Job mais qui fonctionne également
 

job75

XLDnaute Barbatruc
Re : Fonction SI

Bonjour à tous,

Juste une remarque sur la formule de djidji59430.

INDEX($P$9:$R$9;NB.SI($P$9:$R$9;"<>0")) ne va pas si par exemple C10 est vide et F10 non vide.

Mais bien sûr pas de problème si l'on ne saute aucune évaluation.

A+
 

Discussions similaires


Haut Bas